aboutsummaryrefslogtreecommitdiffstats
path: root/main/ccache/APKBUILD
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-06-24 11:01:05 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-06-24 11:01:05 +0000
commit00630fd78516f529daf3005c7defcd6baf4b95f9 (patch)
tree5c2e5d37c90464e39140d0869dccd15ee409a185 /main/ccache/APKBUILD
parentcd39cdcaac4bb080e939cd79288a3fa626528f7f (diff)
parentf80afdde72c0845edc2ce78b3f415cd692269fda (diff)
downloadaports-00630fd78516f529daf3005c7defcd6baf4b95f9.tar.bz2
aports-00630fd78516f529daf3005c7defcd6baf4b95f9.tar.xz
Merge remote branch 'alpine/master'
Diffstat (limited to 'main/ccache/APKBUILD')
-rw-r--r--main/ccache/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/ccache/APKBUILD b/main/ccache/APKBUILD
index 2848bb64d5..b7eb252eb7 100644
--- a/main/ccache/APKBUILD
+++ b/main/ccache/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ccache
-pkgver=2.4
-pkgrel=1
+pkgver=3.0
+pkgrel=0
pkgdesc="ccache is a compiler cache"
url="http://ccache.samba.org/"
license="GPL"
@@ -15,6 +15,10 @@ build ()
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
install -Dm 755 ccache "$pkgdir"/usr/bin/ccache
install -Dm 644 ccache.1 "$pkgdir"/usr/share/man/man1/ccache.1
mkdir -p "$pkgdir"/usr/lib/ccache/bin
@@ -29,4 +33,4 @@ build ()
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-cpp
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-c++
}
-md5sums="73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz"
+md5sums="98145b8ad69a96bf1abf9a52d550e507 ccache-3.0.tar.gz"