aboutsummaryrefslogtreecommitdiffstats
path: root/main/cgdb
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-20 22:10:59 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 10:04:05 +0000
commit9b5d150f90f894c282de3b875f5eedbe89f0bbb2 (patch)
tree6c25c2ec4bdd27759b8114b4890bee286e986c11 /main/cgdb
parent19f4d416d006e4ae92c703ea3dc16fed2287475b (diff)
downloadaports-9b5d150f90f894c282de3b875f5eedbe89f0bbb2.tar.bz2
aports-9b5d150f90f894c282de3b875f5eedbe89f0bbb2.tar.xz
main/cgdb: fix build on mips* (name collision)
There is a variable called "mips" in the code that conflicts with the predefined "mips" macro. Add -std=c11 / -std=c++11 to CFLAGS / CXXFLAGS to force removal of all the non-underscored predefined macros. This is safe because README.md says the project is officially C11/C++11.
Diffstat (limited to 'main/cgdb')
-rw-r--r--main/cgdb/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/cgdb/APKBUILD b/main/cgdb/APKBUILD
index ce04e0707c..24ecbb5487 100644
--- a/main/cgdb/APKBUILD
+++ b/main/cgdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cgdb
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Curses Debugger"
arch="all"
license="GPL-2.0"
@@ -15,6 +15,8 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+ CFLAGS="$CFLAGS -std=c11" \
+ CXXFLAGS="$CXXFLAGS -std=c++11" \
./configure \
--build=$CBUILD \
--host=$CHOST \