aboutsummaryrefslogtreecommitdiffstats
path: root/main/checkbashisms/APKBUILD
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-09-08 19:51:47 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 14:45:04 +0000
commit041e0f9c4faff947c22398af85ec534b4c4369e8 (patch)
treeb5f1054afb7be255701a2d4a370978fd0ce499c9 /main/checkbashisms/APKBUILD
parentef0c973ce651944cb71939a35f8ee9856213bcdd (diff)
downloadaports-041e0f9c4faff947c22398af85ec534b4c4369e8.tar.bz2
aports-041e0f9c4faff947c22398af85ec534b4c4369e8.tar.xz
main/checkbashisms: fix for perl 5.26
add a trivial check
Diffstat (limited to 'main/checkbashisms/APKBUILD')
-rw-r--r--main/checkbashisms/APKBUILD24
1 files changed, 22 insertions, 2 deletions
diff --git a/main/checkbashisms/APKBUILD b/main/checkbashisms/APKBUILD
index 3366e64da6..499560e40a 100644
--- a/main/checkbashisms/APKBUILD
+++ b/main/checkbashisms/APKBUILD
@@ -8,13 +8,33 @@ arch="noarch"
license="GPL2"
options="!check" # No test suite.
depends="perl"
-source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms"
+source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms
+ checkbashisms-perl-5.26.patch"
builddir="$srcdir"
+check() {
+ cd "$builddir"
+ printf '#!/bin/sh\necho "hello world"\n' > ./testfile
+ perl ./checkbashisms --version
+ perl ./checkbashisms ./testfile
+}
+
+prepare() {
+ cd "$builddir"
+
+ # can not patch a symlink
+ src=$(realpath checkbashisms)
+ rm "$pkgname"
+ cp "$src" "$pkgname"
+
+ default_prepare
+}
+
package() {
cd "$builddir"
install -D -m755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="cd9376f4c34773aba79f81b8bb129d912844102e91e363480b9983092efd36c4827e0447242aecfcdb3cfd4cc50e19e105cc645368e8c9735f49c8e381964dd4 checkbashisms"
+sha512sums="cd9376f4c34773aba79f81b8bb129d912844102e91e363480b9983092efd36c4827e0447242aecfcdb3cfd4cc50e19e105cc645368e8c9735f49c8e381964dd4 checkbashisms
+78ef7c52748e3aee4202b316ee22a67b17024fecbdd0e9008a6e68348bf0454a362ed728da550799ffbed4ad916735cef965e9dd83a7d69af257710fbd69d69a checkbashisms-perl-5.26.patch"