aboutsummaryrefslogtreecommitdiffstats
path: root/main/chrony
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-11-19 20:53:08 -0500
committerSören Tempel <soeren+git@soeren-tempel.net>2019-04-17 10:59:31 +0200
commit6847ea68e5298eb7dad4df68d0b57a624d32e66e (patch)
treeef9d4839fff426bd6779b846bbba7682d2994ecb /main/chrony
parentb2ec731f63217ecd1b39adee162bade358d1ffdc (diff)
downloadaports-6847ea68e5298eb7dad4df68d0b57a624d32e66e.tar.bz2
aports-6847ea68e5298eb7dad4df68d0b57a624d32e66e.tar.xz
main/chrony: step closer to openrc documentation
Diffstat (limited to 'main/chrony')
-rw-r--r--main/chrony/APKBUILD2
-rw-r--r--main/chrony/chronyd.initd15
2 files changed, 9 insertions, 8 deletions
diff --git a/main/chrony/APKBUILD b/main/chrony/APKBUILD
index d18599a83b..7bc97c4b8a 100644
--- a/main/chrony/APKBUILD
+++ b/main/chrony/APKBUILD
@@ -88,7 +88,7 @@ sha512sums="4fbb0311c8d363a87edd6f5d1be3d8554da169f260ba23c1ad9e8c567808258c6fd7
067d47224a8c075ec8f63ffc58e65b030fdf228a72c4f03d50a2f2c17414da65bb5d27c7c2e4ba99e909f452041db83eaebe3c9e34c0c8fce18e05ebb489735e fix-tests.patch
b26581ed32680585edea5b8163a0062a87f648394c0f363c77a7d01a36608fcf4d005d9e6ab179ed2827b8a08f598f7bad4801bb5e135cad5107eb77fb19b247 max_resolve_interval.patch
0490770cc214b4ccf76470420e0b33e6c41ad16344d6503973a28346b002e2cee441e9ae982be1a8f21696da26f436f2ce36a5201e9628becb83bad3487d9170 chronyd.confd
-38bad37f75f8465a8494b5eb672fec314a4a15db66e4546cd512d94c19b74e9accd748f4bce238bb1916dd6fb6ab9d1e937e11f83d228dff2264be754cf9e375 chronyd.initd
+5c1a36a4a5f3d7b76c0042c70ff066664a0e2926fff66ce6c0fdcefbc4b70a8b23f660fec59eea45d3c90628bd9a1db7c5d34bbf2b5786d4c6cd9311538b8b6c chronyd.initd
ab38f06bf45888846778ad935e24abb30d13b6805e9a750bc694ff953695fa8c5b33aac560f5f7f96dc46031c1a38660e5c418b6fce6fb34a87908a9a3c99357 chrony.logrotate
0ae453fca3461b6e56a32a9eb6be0d448c39bf0279583222ab2fecef307e1113f082d4e86f957e4baac4f223c5c57804cdea97322678009f3413ab99d54694b6 chrony.conf
eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h"
diff --git a/main/chrony/chronyd.initd b/main/chrony/chronyd.initd
index cc99e5cdf9..1b8b9a42af 100644
--- a/main/chrony/chronyd.initd
+++ b/main/chrony/chronyd.initd
@@ -3,8 +3,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chronyd.rc,v 1.8 2007/03/22 14:32:09 tove Exp $
+command="/usr/sbin/chronyd"
description="NTP daemon"
-PIDFILE="/var/run/chrony/chronyd.pid"
+pidfile="/var/run/chrony/chronyd.pid"
depend() {
need net
@@ -33,9 +34,9 @@ checkconfig() {
# Actually, I tried it, and chrony seems to ignore the pidfile
# option. I'm going to leave it here anyway, since you never
# know if it might be handy
- _cfg_PIDFILE=`awk '/^ *pidfile/{print $2}' "${CFGFILE}"`
- if [ -n "$_cfg_PIDFILE" ] ; then
- PIDFILE="$_cfg_PIDFILE"
+ _cfg_pidfile=`awk '/^ *pidfile/{print $2}' "${CFGFILE}"`
+ if [ -n "$_cfg_pidfile" ] ; then
+ pidfile="$_cfg_pidfile"
fi
fi
return 0
@@ -61,8 +62,8 @@ start() {
ebegin "Starting chronyd"
start-stop-daemon $daemon_args --start --quiet \
- --exec /usr/sbin/chronyd \
- --pidfile "${PIDFILE}" \
+ --exec "${command}" \
+ --pidfile "${pidfile}" \
-- -f "${CFGFILE}" ${ARGS}
eend $? "Failed to start chronyd"
}
@@ -72,6 +73,6 @@ stop() {
ebegin "Stopping chronyd"
start-stop-daemon --stop --quiet \
- --pidfile "${PIDFILE}"
+ --pidfile "${pidfile}"
eend $? "Failed to stop chronyd"
}