aboutsummaryrefslogtreecommitdiffstats
path: root/main/cogl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-16 11:50:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-16 12:16:06 +0000
commit08e98ec7aa1996fb43b704bf7dc189335f688319 (patch)
tree31b685235f1bc6c9899114f366e4ea64d4f94b1a /main/cogl
parent79328ebb1d5f1544d1fc56aac9695ed3259cefbc (diff)
downloadaports-08e98ec7aa1996fb43b704bf7dc189335f688319.tar.bz2
aports-08e98ec7aa1996fb43b704bf7dc189335f688319.tar.xz
main/cogl: upgrade to 1.22.2
Diffstat (limited to 'main/cogl')
-rw-r--r--main/cogl/APKBUILD26
-rw-r--r--main/cogl/fix-an-incorrect-preprocessor-conditional.patch25
2 files changed, 34 insertions, 17 deletions
diff --git a/main/cogl/APKBUILD b/main/cogl/APKBUILD
index 588785c65f..cf8c5b2532 100644
--- a/main/cogl/APKBUILD
+++ b/main/cogl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cogl
-pkgver=1.22.0
+pkgver=1.22.2
pkgrel=0
pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer"
url="http://www.clutter-project.org/"
@@ -14,21 +14,14 @@ depends_dev="glib-dev mesa-dev libdrm-dev libxdamage-dev libxcomposite-dev
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz
+ fix-an-incorrect-preprocessor-conditional.patch
+ "
-_builddir="$srcdir"/cogl-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/cogl-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -48,10 +41,9 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="ab684ec96848d79d22757fb3064820c8 cogl-1.22.0.tar.xz"
-sha256sums="689dfb5d14fc1106e9d2ded0f7930dcf7265d0bc84fa846b4f03941633eeaa91 cogl-1.22.0.tar.xz"
-sha512sums="b19edced4282bd2b828357391fd6175feb483acfec87e344b7719215924dc8996dc8162d7b39d62a108d4f3ebd426caeefeab4e16b6c1962cc3383c239d6c359 cogl-1.22.0.tar.xz"
+sha512sums="2ec99f5ff22683d12925b9a1f748387b47c4506aaf3c5afec851b3b6fe6b7cdfd211fb7e4359bd7a1d1b7cb3cb7fbd257efbcb7d2941d0f133a60bad1c9645e3 cogl-1.22.2.tar.xz
+260618252826f27858f8141effbfff1447472f8a928ca347b454354d4336234a2043b8b7bd8290c3f2f2034422e227168b787a28cb68334caf3626cce94db81f fix-an-incorrect-preprocessor-conditional.patch"
diff --git a/main/cogl/fix-an-incorrect-preprocessor-conditional.patch b/main/cogl/fix-an-incorrect-preprocessor-conditional.patch
new file mode 100644
index 0000000000..74c54f09ec
--- /dev/null
+++ b/main/cogl/fix-an-incorrect-preprocessor-conditional.patch
@@ -0,0 +1,25 @@
+From b583e21d8698dbd58013320cfb47739102efdea7 Mon Sep 17 00:00:00 2001
+From: Kalev Lember <klember at redhat.com>
+Date: Wed, 19 Oct 2016 23:38:28 +0200
+Subject: [PATCH] Fix an incorrect preprocessor conditional
+
+This fixes the build with wayland wayland egl server support disabled.
+---
+ cogl/winsys/cogl-winsys-egl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cogl/winsys/cogl-winsys-egl.c b/cogl/winsys/cogl-winsys-egl.c
+index 39bfd884..4a9f3aa6 100644
+--- a/cogl/winsys/cogl-winsys-egl.c
++++ b/cogl/winsys/cogl-winsys-egl.c
+@@ -1029,7 +1029,7 @@ _cogl_egl_create_image (CoglContext *ctx,
+ egl_ctx = EGL_NO_CONTEXT;
+ else
+ #endif
+-#if COGL_HAS_WAYLAND_EGL_SERVER_SUPPORT
++#ifdef COGL_HAS_WAYLAND_EGL_SERVER_SUPPORT
+ /* The WL_bind_wayland_display spec states that EGL_NO_CONTEXT is to be used
+ * in conjunction with the EGL_WAYLAND_BUFFER_WL target */
+ if (target == EGL_WAYLAND_BUFFER_WL)
+--
+2.11.0