aboutsummaryrefslogtreecommitdiffstats
path: root/main/ddate
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 11:39:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:38:32 -0300
commit86d1e50b1e85c2d0172c4d2a9d279312bbfc7f8b (patch)
tree56cea0ba40da4bd20feac6850c8d8bfd91927084 /main/ddate
parent93ea4ee44090bc69e6fcb644b2005f5b743c67cf (diff)
downloadaports-86d1e50b1e85c2d0172c4d2a9d279312bbfc7f8b.tar.bz2
aports-86d1e50b1e85c2d0172c4d2a9d279312bbfc7f8b.tar.xz
main/ddate: modernize
Diffstat (limited to 'main/ddate')
-rw-r--r--main/ddate/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/main/ddate/APKBUILD b/main/ddate/APKBUILD
index 4cb9dc58ba..20541104b6 100644
--- a/main/ddate/APKBUILD
+++ b/main/ddate/APKBUILD
@@ -2,31 +2,24 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=ddate
pkgver=0.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Convert Gregorian dates to Discordian dates"
url="https://github.com/bo0ts/ddate"
arch="all"
license="Public-Domain"
-depends=""
-depends_dev=""
-makedepends="$depends_dev cmake"
-install=""
+makedepends="cmake"
subpackages="$pkgname-doc"
-source="ddate-$pkgver.tar.gz::${url}/archive/v${pkgver}.tar.gz"
-
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+source="ddate-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
build() {
- cd "$_builddir"
- mkdir build
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
- make PREFIX="/usr"
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
}
package() {
- cd "$_builddir/build"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="5d148e030bee392eb93c5ae519061af0736f2f75eaae916e3efaf927d9f4de8cc72afc4a5121b6fbc0264b73e9f580330a38b97bb78837d447d0b4c1fc29ec06 ddate-0.2.2.tar.gz"