aboutsummaryrefslogtreecommitdiffstats
path: root/main/debootstrap/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-08-18 20:46:27 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-08-20 14:27:33 +0000
commit3733c0de8c20ef730ad0e1636e81e9233696e2ca (patch)
treeb9948eea66609768c7d9f43b8f36ea0f6233b9d7 /main/debootstrap/APKBUILD
parent94f1ee94e271eef3374602739673b99b5c3231d9 (diff)
downloadaports-3733c0de8c20ef730ad0e1636e81e9233696e2ca.tar.bz2
aports-3733c0de8c20ef730ad0e1636e81e9233696e2ca.tar.xz
main/debootstrap: remove pkgdetails.c
In my opinion it doesn't belong in this package, it could be shipped by a separate package but I don't think that it is that useful.
Diffstat (limited to 'main/debootstrap/APKBUILD')
-rw-r--r--main/debootstrap/APKBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index d8d213754a..c83dca4fed 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -2,46 +2,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=debootstrap
pkgver=1.0.72
-pkgrel=1
+pkgrel=2
pkgdesc="Debian/Ubuntu bootstrap scripts"
url="http://packages.qa.debian.org/d/debootstrap.html"
-arch="all"
+arch="noarch"
license="GPL2"
depends="dpkg tar"
makedepends=""
install=""
subpackages="$pkgname-doc"
-source="http://ftp.de.debian.org/debian/pool/main/d/debootstrap/debootstrap_$pkgver.tar.gz
- pkgdetails.c
+source="http://ftp.de.debian.org/debian/pool/main/d/$pkgname/${pkgname}_${pkgver}.tar.gz
makedev.sh"
-_builddir="$srcdir"/debootstrap-$pkgver
-build() {
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
chmod +x "$srcdir/makedev.sh"
- ${CC:-gcc} $CFLAGS $LDFLAGS -o "$_builddir"/pkgdetails \
- "$srcdir"/pkgdetails.c || return 1
}
package() {
cd "$_builddir"
-
- # This can only be done in a fakeroot
make MAKEDEV="$srcdir/makedev.sh" \
devices.tar.gz || return 1
make DESTDIR="$pkgdir" install || return 1
- install -Dm755 pkgdetails \
- "$pkgdir"/usr/lib/debootstrap/pkgdetails || return 1
install -Dm644 $pkgname.8 \
"$pkgdir"/usr/share/man/man8/$pkgname.8 || return 1
}
md5sums="0cacf6e3bd8b566e921d2a326d6fd2bd debootstrap_1.0.72.tar.gz
-66b6fb6d862ba4886701c9b056088479 pkgdetails.c
ef5038e52173de7a18c37a0925ccf383 makedev.sh"
sha256sums="90f4cf1390326f020b9192b6a45ba1d323fffab9c22c6f62451780e6f5482f8d debootstrap_1.0.72.tar.gz
-1cf1644e8400693fd41d378f972c15fa7b32f3282117ea967c995705256a84d6 pkgdetails.c
3f26318b59c7697205285d04eb68a4c65905faedd7bbcb4e53e803f9ea8e5c97 makedev.sh"
sha512sums="b8f186b13f66789e96f775337d06821cfb464e35dd661a2bff1420bfb1254cf85ce9eb46be1a27dad7a462628e441cbfcdfffaf12ee5a394d15c248882295848 debootstrap_1.0.72.tar.gz
-432313c8aef4974f21cb81b48d9f1c319692325f24a456e460e6f92c6a15ade7f29dfee4bf2ab3664c90b09d1f16e46cb8dd898ebd317f2547e63a64a773d971 pkgdetails.c
71f1dfe7d785cf5f4b2db7e4de01b5e542b33a1a49194a53665d4d68b5de47fc3c5b37ad2d1a7c37fb14d10c6758fa2fb043bd68a6fbb8b9dba90fb071a9db9c makedev.sh"