aboutsummaryrefslogtreecommitdiffstats
path: root/main/devicemaster-linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-14 14:51:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-14 18:50:09 +0000
commita0cc5c571adc1973d1cd1cda25292fcb34c8a3f3 (patch)
tree32776b50efa37ffb74a29488f83167e728eb5921 /main/devicemaster-linux-grsec
parent2d5b573bdf9ce0fb6770f8c0f0d0a16feb52ab4f (diff)
downloadaports-a0cc5c571adc1973d1cd1cda25292fcb34c8a3f3.tar.bz2
aports-a0cc5c571adc1973d1cd1cda25292fcb34c8a3f3.tar.xz
main/devicemaster-linux-grsec: upgrade to 7.15 and kernel 4.9.9
Diffstat (limited to 'main/devicemaster-linux-grsec')
-rw-r--r--main/devicemaster-linux-grsec/APKBUILD12
-rw-r--r--main/devicemaster-linux-grsec/nslink.patch32
2 files changed, 10 insertions, 34 deletions
diff --git a/main/devicemaster-linux-grsec/APKBUILD b/main/devicemaster-linux-grsec/APKBUILD
index e742c3dfb6..1fd60cf8db 100644
--- a/main/devicemaster-linux-grsec/APKBUILD
+++ b/main/devicemaster-linux-grsec/APKBUILD
@@ -2,7 +2,7 @@
_flavor=grsec
_kpkg=linux-$_flavor
-_kver=4.4.47
+_kver=4.9.9
_kpkgrel=0
_mypkgrel=0
@@ -13,7 +13,7 @@ _realname=devicemaster-linux
pkgname=${_realname}-${_flavor}
pkgver=$_kver
# when changing _realver we *must* bump _mypkgrel
-_realver=7.11
+_realver=7.15
pkgrel=$(( $_kpkgrel + $_mypkgrel ))
pkgdesc="NS-Link Device Drivers $_realver for linux-$_flavor"
url="http://www.comtrol.com/resources/product-resources-white-papers/ns-link-device-drivers"
@@ -25,7 +25,6 @@ install=
install_if="$_kpkg=$_kpkgver $_realname"
subpackages=""
source="http://dev.alpinelinux.org/archive/devicemaster-linux/devicemaster-linux-$_realver.tar.gz
- nslink.patch
"
prepare() {
@@ -63,9 +62,4 @@ package() {
cp *.ko "$pkgdir/lib/modules/${_abi_release}/misc/" || return 1
}
-md5sums="0e79cf4afe5503087454d052f33847a9 devicemaster-linux-7.11.tar.gz
-93304a282dab87658481fdce61d97f5c nslink.patch"
-sha256sums="9901966cf6a696f07a7d3f79c8fc5d6dbc5340fd36ea785cf27577b1fcadfc04 devicemaster-linux-7.11.tar.gz
-bb875877b13fb5a477598b17c94f0b8f3e08812c37d90db63fcb7de78554ddff nslink.patch"
-sha512sums="dade8220f25c32e38520fd9267f18f2af0bcc14e84b422f77d6cdf7a23d4f14512182176039686ec898d6e4c390751318bc0c7aa7f74e4aa9a94d411b3c774d8 devicemaster-linux-7.11.tar.gz
-f3549770d7253595d51466973d112a1b63c3aad9b73cb3033718031327bfd4ac6f182540bc6a9c44a0919431b3ffa38c382923874a9f8c856a194ab768464fe7 nslink.patch"
+sha512sums="794f680613db6462f1452e32f17ab7e30e637d0a77d4c7c5cf43650776f5ec0d3c5144ebdf92fc5bf0f2f0fba456c2710d2cd2280981a208ff936b472388c3ba devicemaster-linux-7.15.tar.gz"
diff --git a/main/devicemaster-linux-grsec/nslink.patch b/main/devicemaster-linux-grsec/nslink.patch
index 79d7fc444f..98703430f8 100644
--- a/main/devicemaster-linux-grsec/nslink.patch
+++ b/main/devicemaster-linux-grsec/nslink.patch
@@ -1,8 +1,8 @@
diff --git a/nslink.c b/nslink.c
-index 6de4618..d67d8b0 100755
+index bf4a922..1672325 100755
--- a/nslink.c
+++ b/nslink.c
-@@ -113,6 +113,7 @@
+@@ -117,6 +117,7 @@
#include <linux/slab.h>
#include <linux/time.h>
#include <linux/delay.h>
@@ -10,7 +10,7 @@ index 6de4618..d67d8b0 100755
#if LINUX_VERSION_CODE >= VERSION_CODE(2,6,36) && LINUX_VERSION_CODE < VERSION_CODE(2,6,39)
#include <linux/smp_lock.h>
#endif
-@@ -2864,7 +2865,7 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
+@@ -2874,7 +2875,7 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
info = nrp_table[line];
@@ -19,7 +19,7 @@ index 6de4618..d67d8b0 100755
if (!info->si) {
DebugOpenErr("ttySI%d info->si==NULL: return -ENODEV\n", line);
-@@ -2880,9 +2881,9 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
+@@ -2890,9 +2891,9 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
ret = tty_port_open(&info->port, tty, filp);
if (ret && ret != -ERESTARTSYS)
@@ -31,7 +31,7 @@ index 6de4618..d67d8b0 100755
return ret;
}
-@@ -2925,9 +2926,9 @@ static void nrp_port_shutdown(struct tty_port *port)
+@@ -2935,9 +2936,9 @@ static void nrp_port_shutdown(struct tty_port *port)
static void nrp_close(struct tty_struct *tty, struct file *filp)
{
struct nr_port *info = (struct nr_port *) tty->driver_data;
@@ -43,25 +43,7 @@ index 6de4618..d67d8b0 100755
}
static void nrp_set_termios(struct tty_struct *tty, struct ktermios *old_termios)
-@@ -4094,7 +4095,7 @@ static void tcp_check_rx(struct si_state *si)
- #endif
- msg.msg_control = NULL;
-
-- rc = si->SOCK_PROT(tcp_sk)->recvmsg(NULL, si->tcp_sk, &msg, pktlen, 1, 0, NULL);
-+ rc = si->SOCK_PROT(tcp_sk)->recvmsg(si->tcp_sk, &msg, pktlen, 1, 0, NULL);
-
- if (rc < 0) {
- printk(KERN_INFO "nslink: CheckRxTcp recvmsg err %d\n", rc);
-@@ -4155,7 +4156,7 @@ static void tcp_send_packet(struct si_state *si, int len)
- oldfs = get_fs();
- set_fs(KERNEL_DS);
-
-- rc = si->tcp_sock->ops->sendmsg(NULL, si->tcp_sock, &msg, len);
-+ rc = si->tcp_sock->ops->sendmsg(si->tcp_sock, &msg, len);
-
- set_fs(oldfs);
-
-@@ -4785,7 +4786,7 @@ static int free_si_box(int boxid)
+@@ -4799,7 +4800,7 @@ static int free_si_box(int boxid)
info = nrp_table[i + si->base_port];
if (!info)
continue;
@@ -70,7 +52,7 @@ index 6de4618..d67d8b0 100755
DebugOpenErr("Attempt to free_si_box() with port open\n");
return -EBUSY;
}
-@@ -5007,7 +5008,7 @@ static int port_proc_show(struct seq_file *m, void *v)
+@@ -5021,7 +5022,7 @@ static int port_proc_show(struct seq_file *m, void *v)
for (i=0; i<NumElements(nrp_table); ++i) {
struct nr_port *info = nrp_table[i];
if (info) {