aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcpcd-ui/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@bernewireless.net>2011-07-05 19:40:43 +0200
committerFabian Affolter <fabian@bernewireless.net>2011-07-05 19:40:43 +0200
commit7f9851115264bca9bce3926ddb29e533a23929dd (patch)
treeb0426fc489e4dad582f34b25d6f93354a65f5c0f /main/dhcpcd-ui/APKBUILD
parent5dac3f219058736f6e19b7bec2b1cc2b1b300981 (diff)
parent269fc1049583d36e07153215fe535f88947ea98b (diff)
downloadaports-7f9851115264bca9bce3926ddb29e533a23929dd.tar.bz2
aports-7f9851115264bca9bce3926ddb29e533a23929dd.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'main/dhcpcd-ui/APKBUILD')
-rw-r--r--main/dhcpcd-ui/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/dhcpcd-ui/APKBUILD b/main/dhcpcd-ui/APKBUILD
new file mode 100644
index 0000000000..56441cefd0
--- /dev/null
+++ b/main/dhcpcd-ui/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhcpcd-ui
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="A GTK+ monitor and configuration GUI for dhcpcd"
+url="http://roy.marples.name/projects/dhcpcd-ui"
+arch="all"
+license="BSD-2"
+depends="dhcpcd-dbus hicolor-icon-theme"
+makedepends="glib-dev gtk+-dev dbus-dev libnotify-dev pkgconfig"
+install=
+subpackages="$pkgname-doc"
+source="http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" AUTOSTARTDIR=/etc/xdg/autostart install
+}
+
+md5sums="a42b15650de093bcd3dd60fb94a483f7 dhcpcd-ui-0.5.1.tar.bz2"