aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcpcd/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 16:13:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 16:41:45 +0200
commit767d22bd00c7aac4d3b1b48a4ce864b65bdccfc2 (patch)
tree63bc90a7b7dcd67c9311626107ea37498e16511a /main/dhcpcd/APKBUILD
parentcbf091ceed367e64cd7f6819a09a2c4a2f151e31 (diff)
downloadaports-767d22bd00c7aac4d3b1b48a4ce864b65bdccfc2.tar.bz2
aports-767d22bd00c7aac4d3b1b48a4ce864b65bdccfc2.tar.xz
main/dhcpcd: upgrade to 7.0.2 and improve abuild
Diffstat (limited to 'main/dhcpcd/APKBUILD')
-rw-r--r--main/dhcpcd/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index cf75c9a92e..0374c8cdaa 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -2,26 +2,25 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dhcpcd
-pkgver=6.11.5
-pkgrel=2
+pkgver=7.0.2
+pkgrel=0
pkgdesc="RFC2131 compliant DHCP client"
url="https://roy.marples.name/projects/dhcpcd/"
arch="all"
license="BSD-2-Clause"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers bsd-compat-headers dbus-dev"
-install=""
+makedepends="linux-headers bsd-compat-headers dbus-dev"
+install="$pkgname.post-upgrade"
subpackages="$pkgname-doc $pkgname-openrc"
source="http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.xz
busybox-logger.patch
fix-chrony-conf-location.patch
dhcpcd.initd
"
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+
CFLAGS="$CFLAGS -D_GNU_SOURCE -DHAVE_PRINTF_M"
./configure \
--build=$CBUILD \
@@ -45,12 +44,13 @@ check() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/dhcpcd.initd \
"$pkgdir"/etc/init.d/dhcpcd
}
-sha512sums="a23d5dde66567c4addbc86c8b3fbf2c5d4dba3b463659729778a310306ab0e949be8998154ef15401ac2d289bde2f090d44492bba6a1becd2f01890d4efe7051 dhcpcd-6.11.5.tar.xz
-83dc7bfd36b6b416c931775bb35a0d2951ed04c421195c45bfed80a11a7adbed7c80ade1c1246847c2fb1bf15a7b6e83100f16605ee84f750440d7bc9f7f5ef3 busybox-logger.patch
-4e07c886d89aa4962e683383098d343030a24838e3c3d86ac79c00aad87dcaf41352ac04556a2bf0e00c1b9bad370351e254e83fa76f6e299102fd292b5f6a70 fix-chrony-conf-location.patch
+sha512sums="f5b1407199163fb994519bc1b5a70ad043f00f263e3b254da5d519d1c6b689a4a5a8bcef3bf42401826984e273c2ead38249fcfe99129b87034f90de2fc46ecd dhcpcd-7.0.2.tar.xz
+692b2c8c75166fabd512a7cc69c650f9391e0f682ce9cbe1771bfa44e82dcf09e322c46493c45ca75000f479d3cddde306754ba31d28a798a15e2b79a56045f0 busybox-logger.patch
+1c19eed0f7a008ee96ea392beb327169ff8c83fc27fed20f65f05c9125f60629ebe3474c5e6a7cf4aeeea448fde4264c9b84916efacd67d47ab908c47b1fc3a5 fix-chrony-conf-location.patch
6d3220155f2d9ed3e3a00afd378eeb70d435e19804201f8bb35498f1f7f3dfdaeaa2f4a01a18f5e96b457d9c173bc6a206b3e67ebf6d95da7e7b350dcd153fde dhcpcd.initd"