aboutsummaryrefslogtreecommitdiffstats
path: root/main/directfb/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:13:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:14:22 +0000
commit1458bb599ac455f62657a623c23f44c4910f2802 (patch)
tree393508fae0ee51ae84521da7fd48c786449a092c /main/directfb/APKBUILD
parent278799f02dc254890fe9ed333a75167a875e3536 (diff)
downloadaports-1458bb599ac455f62657a623c23f44c4910f2802.tar.bz2
aports-1458bb599ac455f62657a623c23f44c4910f2802.tar.xz
main/directfb: move from testing
needed by sdl2
Diffstat (limited to 'main/directfb/APKBUILD')
-rw-r--r--main/directfb/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/main/directfb/APKBUILD b/main/directfb/APKBUILD
new file mode 100644
index 0000000000..d0b036fd01
--- /dev/null
+++ b/main/directfb/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=directfb
+pkgver=1.7.7
+pkgrel=1
+pkgdesc="Library for hw graphics acceleration, input dev, windowing system on top of the Linux fb device"
+arch="all"
+url="https://github.com/DirectFB/directfb"
+license="LGPL"
+makedepends="zlib-dev freetype-dev libdrm-dev libpng-dev perl tslib tslib-dev autoconf automake libtool"
+depends=""
+subpackages="$pkgname-doc $pkgname-dev"
+builddir="${srcdir}/DirectFB-${pkgver}"
+source="
+ http://sources.webos-ports.org/downloads/DirectFB-$pkgver.tar.gz
+ 0001-directfb-fix-musl-compile.patch
+ 0002-Fix-musl-PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP-comp.patch
+ 0003-remove-set-gamma-ramp.patch
+ 0004-disable-fusion_dispatch.patch
+ 0005-fix-tslib-configure.patch
+ 0006-fix-client-gfx_state-initialisation.patch
+ "
+
+build() {
+ cd "${builddir}"
+ autoconf
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-static \
+ --disable-zlib \
+ --disable-x11 \
+ --enable-fbdev \
+ --disable-vnc \
+ --disable-osx \
+ --disable-mesa \
+ --enable-drmkms \
+ --enable-freetype \
+ --with-inputdrivers=input_hub,keyboard,linuxinput,ps2mouse,serialmouse,tslib \
+ --with-gfxdrivers=omap
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+}
+
+sha512sums="c9ce8ffe7d7d17b0351da6a031db7345f31fb7112545f9352834ad33225a93e6284ef0e576ef5fc595bc9060c1756051322fa20f7b5b3444b68d7f05bd1ba494 DirectFB-1.7.7.tar.gz
+d9325c228a534d2d2b93b4dacf896fc12c703b9e08adf1ae8f5baea2a0ed5c4d07d56b8bc63dc605362f093624eab40686b43028ef15a78a01bc10e5f41c16bc 0001-directfb-fix-musl-compile.patch
+ed3bf9bf76616174aca6ae92fd9873c9452951b8a2acb60e1ccbbea0c4a7c9766e510899bc8f58c24dd5888c1e7e1f0a0d4a823f0bd9e03a4c9d2a54fb714221 0002-Fix-musl-PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP-comp.patch
+bd1d0738c48411e8e065b8a250c1b31334ac65b26a8f6c91d5ad167a4d8fdac1de862c05940567e48fc740dd45fbecf906ebdfbff63420d4f86bee7a3a0746ee 0003-remove-set-gamma-ramp.patch
+d68002702f3521a71405bb403b874dced5b123a2de037c9eb05667123a578c0e9a9f13a822fd8d77e31a83f1e1cc8df1d8511f7d2f427688d5ef6ae0fff448c5 0004-disable-fusion_dispatch.patch
+c768ca7a4dae7fc0cd7d4fa559ab74adb6b5f21245e0f9b5d56af15b20effc04e6739e86d52d65c902c5e76ad72e966cd9db68f57a9bad11a004525825d443a4 0005-fix-tslib-configure.patch
+6b118928c2ebe58654e1bf32433b084f4dc150526eec1b53f9eb4b856aee25733bd8d6114fde973fcb64416e4146f458cdb75e5836d7507cf802b84e44544462 0006-fix-client-gfx_state-initialisation.patch"