aboutsummaryrefslogtreecommitdiffstats
path: root/main/dnssec-root
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-23 17:24:14 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-25 18:01:07 +0200
commit5bbf258d928ed4e36e02f83526ae831ed4d8a409 (patch)
tree660f1399b2b4ebed60610650c19196a631422aeb /main/dnssec-root
parent20b82cbb2c36a2db7f3121eb2b6bb23092f6f5cd (diff)
downloadaports-5bbf258d928ed4e36e02f83526ae831ed4d8a409.tar.bz2
aports-5bbf258d928ed4e36e02f83526ae831ed4d8a409.tar.xz
main/dnssec-root: make build reproducible
The same key is not always written to the same file. Since we simply concatenate it we might end up with different trusted keys files. Sort the file using the key string to make the build reproducible.
Diffstat (limited to 'main/dnssec-root')
-rw-r--r--main/dnssec-root/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/dnssec-root/APKBUILD b/main/dnssec-root/APKBUILD
index 0af5f66fe0..205a382116 100644
--- a/main/dnssec-root/APKBUILD
+++ b/main/dnssec-root/APKBUILD
@@ -24,7 +24,7 @@ build() {
package() {
cd "$builddir"
- cat ksk-as-dnskey.txt* > trusted-key.key
+ sort -k 6 ksk-as-dnskey.txt* > trusted-key.key
install -Dm644 trusted-key.key \
"$pkgdir"/usr/share/$pkgname/trusted-key.key
}