aboutsummaryrefslogtreecommitdiffstats
path: root/main/dpkg
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 13:39:19 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-28 14:05:32 +0100
commitc9e8d8eb4953da454520ad29a41041e732bbecf1 (patch)
treecc8dbcd8cdc2456709cb76ab00b7ba4f57217e87 /main/dpkg
parentfc1a2f711cda681be1cec93a00f70c430eebfa88 (diff)
downloadaports-c9e8d8eb4953da454520ad29a41041e732bbecf1.tar.bz2
aports-c9e8d8eb4953da454520ad29a41041e732bbecf1.tar.xz
main/dpkg: drop dependency on xz
Diffstat (limited to 'main/dpkg')
-rw-r--r--main/dpkg/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/main/dpkg/APKBUILD b/main/dpkg/APKBUILD
index 4c8dcee58d..dd493327c5 100644
--- a/main/dpkg/APKBUILD
+++ b/main/dpkg/APKBUILD
@@ -1,19 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dpkg
pkgver=1.19.7
-pkgrel=0
+pkgrel=1
pkgdesc="The Debian Package Manager"
url="https://packages.debian.org/dpkg"
arch="all"
license="GPL-2.0-or-later BSD-2-Clause"
-depends="tar xz"
+depends="tar"
options="!check"
makedepends="bzip2-dev linux-headers perl zlib-dev"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://deb.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.xz"
+source="https://deb.debian.org/debian/pool/main/d/dpkg/dpkg_$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,7 +30,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# Add missing dir & files