aboutsummaryrefslogtreecommitdiffstats
path: root/main/ed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-18 16:49:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-18 16:50:20 +0000
commitafcc66154c19126e5a2bd757465bb602f69db1bf (patch)
treec8ae94f6f7408c60248e039672e1c859b0d3a796 /main/ed
parent8396e50c7aba7dc2493d8c0b286a965f2583c3b3 (diff)
downloadaports-afcc66154c19126e5a2bd757465bb602f69db1bf.tar.bz2
aports-afcc66154c19126e5a2bd757465bb602f69db1bf.tar.xz
main/ed: move from testing
needed by bc
Diffstat (limited to 'main/ed')
-rw-r--r--main/ed/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/ed/APKBUILD b/main/ed/APKBUILD
new file mode 100644
index 0000000000..7079ef1167
--- /dev/null
+++ b/main/ed/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=ed
+pkgver=1.14.2
+pkgrel=0
+pkgdesc="GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files"
+url="https://www.gnu.org/software/ed/"
+arch="all"
+license="GPL"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
+
+builddir=$srcdir/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make all
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="653bcb89788b2d18c726336fb6f17678ac031fe6ea03a93ff248886a075c867ba5423d5471401e44cbdcce3b4cb766b621ca7b70d76881f5044ec3412767b11f ed-1.14.2.tar.lz"