aboutsummaryrefslogtreecommitdiffstats
path: root/main/esh
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-07-31 20:55:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-07-31 20:55:26 +0200
commit485f537b76a4bef74d2b89af72c473aa680b04a1 (patch)
tree6d4e958e79faacd1bd3968b4ec411d98360017f0 /main/esh
parentb3cfd0d41a4dc19e9d5648e7402bef1930903a7c (diff)
downloadaports-485f537b76a4bef74d2b89af72c473aa680b04a1.tar.bz2
aports-485f537b76a4bef74d2b89af72c473aa680b04a1.tar.xz
main/esh: move from community
Diffstat (limited to 'main/esh')
-rw-r--r--main/esh/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/esh/APKBUILD b/main/esh/APKBUILD
new file mode 100644
index 0000000000..9fc5598495
--- /dev/null
+++ b/main/esh/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=esh
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Simple template system based on shell"
+url="https://github.com/jirutka/esh"
+arch="noarch"
+license="MIT"
+makedepends="asciidoctor"
+subpackages="$pkgname-doc"
+source="https://github.com/jirutka/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
+}
+
+sha512sums="6c1a55a9301af37272223b1155b69000667bb86fb95e5533ee08ecafbaaafb3d93a63e538b8511e33268dfc04a9cbb767308bc5795e019b90c72e8ce687d55b6 esh-0.3.0.tar.gz"