aboutsummaryrefslogtreecommitdiffstats
path: root/main/fftw
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-11-19 14:01:30 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-11-19 14:01:30 +0000
commit33e66e9b76d9100bece0da72f7da51643e00acad (patch)
tree2e676796f697e96f05a16986858a1a0e9277cd89 /main/fftw
parent4796dfe17d33cb32558ccff1c2eac5f36d5db667 (diff)
downloadaports-33e66e9b76d9100bece0da72f7da51643e00acad.tar.bz2
aports-33e66e9b76d9100bece0da72f7da51643e00acad.tar.xz
main/fftw: fix arm build (neon works only with single precision)
Diffstat (limited to 'main/fftw')
-rw-r--r--main/fftw/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/main/fftw/APKBUILD b/main/fftw/APKBUILD
index 9df071f6d8..9bc7a4b46e 100644
--- a/main/fftw/APKBUILD
+++ b/main/fftw/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=fftw
pkgver=3.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="fastest fourier transform in the west"
url="http://www.fftw.org/"
license="GPL"
@@ -33,14 +33,14 @@ build() {
long-double)_cf="--enable-long-double";;
esac
- if [ "$i" = "single" ] || [ "$i" = "double" ]; then
- case "$CARCH" in
- x86_64)_cf="$_cf --enable-sse2 --enable-avx";;
- armhf)_cf="$_cf --enable-neon";;
- esac
- fi
+ case "$i--$CARCH" in
+ single--x86_64 | double--x86_64)
+ _cf="$_cf --enable-sse2 --enable-avx";;
+ single--arm*)
+ _cf="$_cf --enable-neon";;
+ esac
- msg "Building for $i precision"
+ msg "Building for $i precision ($_cf)"
cd "$_builddir"/$i
./configure \
--build=$CBUILD \