aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch/0001-sofia-sip-byte-order.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-07-27 11:31:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-27 16:52:02 +0000
commit63fd7f98905c4c9d338e4b7b22f58dc47f6d99b8 (patch)
tree5045a6c8a134bdaa6abbdad28fbf275a953277c4 /main/freeswitch/0001-sofia-sip-byte-order.patch
parentfdc727072d45fcbf94e931db85d2d2c29acae3cb (diff)
downloadaports-63fd7f98905c4c9d338e4b7b22f58dc47f6d99b8.tar.bz2
aports-63fd7f98905c4c9d338e4b7b22f58dc47f6d99b8.tar.xz
main/freeswitch: upgrade to 1.6.9
Diffstat (limited to 'main/freeswitch/0001-sofia-sip-byte-order.patch')
-rw-r--r--main/freeswitch/0001-sofia-sip-byte-order.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/freeswitch/0001-sofia-sip-byte-order.patch b/main/freeswitch/0001-sofia-sip-byte-order.patch
new file mode 100644
index 0000000000..6344a3557d
--- /dev/null
+++ b/main/freeswitch/0001-sofia-sip-byte-order.patch
@@ -0,0 +1,45 @@
+From fa276af16c696e505f66e6ca18ab343f985e8f2b Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 27 Jul 2016 07:31:16 +0000
+Subject: [PATCH] sofia-sip: byte-order
+
+---
+ libs/sofia-sip/libsofia-sip-ua/tport/ws.c | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/libs/sofia-sip/libsofia-sip-ua/tport/ws.c b/libs/sofia-sip/libsofia-sip-ua/tport/ws.c
+index 7fe9f18..27d95b2 100644
+--- a/libs/sofia-sip/libsofia-sip-ua/tport/ws.c
++++ b/libs/sofia-sip/libsofia-sip-ua/tport/ws.c
+@@ -703,14 +703,12 @@ ssize_t ws_close(wsh_t *wsh, int16_t reason)
+
+ uint64_t hton64(uint64_t val)
+ {
+- if (__BYTE_ORDER == __BIG_ENDIAN) return (val);
+- else return __bswap_64(val);
++ return be64toh(val);
+ }
+
+ uint64_t ntoh64(uint64_t val)
+ {
+- if (__BYTE_ORDER == __BIG_ENDIAN) return (val);
+- else return __bswap_64(val);
++ return htobe64(val);
+ }
+
+
+--
+2.9.1
+
+diff --git a/libs/sofia-sip/configure.ac b/libs/sofia-sip/configure.ac
+index ca6bd3a..3d5677b 100644
+--- a/libs/sofia-sip/configure.ac
++++ b/libs/sofia-sip/configure.ac
+@@ -218,7 +218,6 @@ fi
+ AC_C_CONST
+ AC_C_INLINE
+ AC_C_INLINE_DEFINE
+-AC_C_BIGENDIAN(AC_DEFINE([__BYTE_ORDER],__BIG_ENDIAN,[Big Endian]),AC_DEFINE([__BYTE_ORDER],__LITTLE_ENDIAN,[Little Endian]))
+
+ AC_C_VAR_FUNC
+ AC_C_MACRO_FUNCTION