aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-15 14:40:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-15 14:41:22 +0000
commit76efd324ce9147a3e8f21dd6eb82b684eba406dc (patch)
treeb43d531826d150a4f0922d5c3f22dfe3bd06928e /main/freeswitch
parent0ef6fbcfd73ea64bf4aefae0fea776d432cc8a84 (diff)
downloadaports-76efd324ce9147a3e8f21dd6eb82b684eba406dc.tar.bz2
aports-76efd324ce9147a3e8f21dd6eb82b684eba406dc.tar.xz
main/freeswitch: upgrade to 1.6.2
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch83
-rw-r--r--main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch28
-rw-r--r--main/freeswitch/APKBUILD89
-rw-r--r--main/freeswitch/fix-voicemail-greet-reset.patch48
-rw-r--r--main/freeswitch/freeswitch-mod_shout-textrels.patch11
-rw-r--r--main/freeswitch/libshout-disable-examples.patch19
-rw-r--r--main/freeswitch/modules.conf8
-rw-r--r--main/freeswitch/musl-fixes.patch82
-rw-r--r--main/freeswitch/system-lame.patch26
9 files changed, 27 insertions, 367 deletions
diff --git a/main/freeswitch/0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch b/main/freeswitch/0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
deleted file mode 100644
index ca6f36f45e..0000000000
--- a/main/freeswitch/0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From f43510f2430150b7f425d614f6bc605fcd3ed0ce Mon Sep 17 00:00:00 2001
-From: Anthony Minessale <anthm@freeswitch.org>
-Date: Wed, 19 Aug 2015 11:42:11 -0500
-Subject: [PATCH] FS-7969 #resolve [Freeswitch segfaults due to
- pthread_setschedparam() on a thread that has exited] #comment please test
- this fix which was verified working
-
----
- libs/apr/.update | 2 +-
- libs/apr/include/arch/unix/apr_arch_threadproc.h | 1 +
- libs/apr/threadproc/unix/thread.c | 29 ++++++++++++++----------
- 3 files changed, 19 insertions(+), 13 deletions(-)
-
-diff --git a/libs/apr/.update b/libs/apr/.update
-index 1aeaab4..6e68952 100644
---- a/libs/apr/.update
-+++ b/libs/apr/.update
-@@ -1 +1 @@
--Tue Aug 27 13:58:18 EDT 2013
-+Wed Aug 19 11:38:49 CDT 2015
-diff --git a/libs/apr/include/arch/unix/apr_arch_threadproc.h b/libs/apr/include/arch/unix/apr_arch_threadproc.h
-index bd9359a..348c6c5 100644
---- a/libs/apr/include/arch/unix/apr_arch_threadproc.h
-+++ b/libs/apr/include/arch/unix/apr_arch_threadproc.h
-@@ -55,6 +55,7 @@ struct apr_thread_t {
- void *data;
- apr_thread_start_t func;
- apr_status_t exitval;
-+ int priority;
- };
-
- struct apr_threadattr_t {
-diff --git a/libs/apr/threadproc/unix/thread.c b/libs/apr/threadproc/unix/thread.c
-index 8859e79..165dddc 100644
---- a/libs/apr/threadproc/unix/thread.c
-+++ b/libs/apr/threadproc/unix/thread.c
-@@ -135,6 +135,19 @@ APR_DECLARE(apr_status_t) apr_threadattr_guardsize_set(apr_threadattr_t *attr,
- static void *dummy_worker(void *opaque)
- {
- apr_thread_t *thread = (apr_thread_t*)opaque;
-+
-+#ifdef HAVE_PTHREAD_SETSCHEDPARAM
-+ if (thread->priority) {
-+ int policy;
-+ struct sched_param param = { 0 };
-+ pthread_t tt = pthread_self();
-+
-+ pthread_getschedparam(tt, &policy, &param);
-+ param.sched_priority = thread->priority;
-+ pthread_setschedparam(tt, policy, &param);
-+ }
-+#endif
-+
- return thread->func(thread, thread->data);
- }
-
-@@ -174,19 +187,11 @@ APR_DECLARE(apr_status_t) apr_thread_create(apr_thread_t **new,
- return stat;
- }
-
-- if ((stat = pthread_create(&tt, temp, dummy_worker, (*new))) == 0) {
--
--#ifdef HAVE_PTHREAD_SETSCHEDPARAM
-- if (attr && attr->priority) {
-- int policy;
-- struct sched_param param = { 0 };
--
-- pthread_getschedparam(tt, &policy, &param);
-- param.sched_priority = attr->priority;
-- pthread_setschedparam(tt, policy, &param);
-- }
--#endif
-+ if (attr && attr->priority) {
-+ (*new)->priority = attr->priority;
-+ }
-
-+ if ((stat = pthread_create(&tt, temp, dummy_worker, (*new))) == 0) {
- *(*new)->td = tt;
-
- return APR_SUCCESS;
---
-2.5.0
-
diff --git a/main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch b/main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
deleted file mode 100644
index 328d5edbec..0000000000
--- a/main/freeswitch/0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7aba5d52ee609e63ede7e76ab955179e9c61244d Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 7 Sep 2015 16:23:56 +0200
-Subject: [PATCH] FS-8131: [mod_voicemail] fix disallowed empty password set
-
-Prevent users to change password to an empty password when
-allow-empty-password-auth is set to true.
----
- src/mod/applications/mod_voicemail/mod_voicemail.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/mod/applications/mod_voicemail/mod_voicemail.c b/src/mod/applications/mod_voicemail/mod_voicemail.c
-index da6180a..6300211 100644
---- a/src/mod/applications/mod_voicemail/mod_voicemail.c
-+++ b/src/mod/applications/mod_voicemail/mod_voicemail.c
-@@ -2305,6 +2305,9 @@ static void voicemail_check_main(switch_core_session_t *session, vm_profile_t *p
- switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Domain", domain_name);
- switch_channel_event_set_data(channel, params);
-
-+ if (zstr(buf) && !profile->allow_empty_password_auth) {
-+ fail = 1;
-+ }
- if (switch_xml_locate_user("id", myid, domain_name, switch_channel_get_variable(channel, "network_addr"),
- &xx_domain_root, &xx_domain, &xx_user, NULL, params) == SWITCH_STATUS_SUCCESS) {
- switch_xml_t x_result;
---
-2.5.1
-
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index c676cf7116..307c21d19f 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-pkgver=1.4.20
-pkgrel=5
+pkgver=1.6.2
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -12,20 +12,26 @@ depends=""
pkgusers="freeswitch"
options="!configsub"
pkggroups="freeswitch"
-makedepends="bash
+makedepends="
+ bash
bsd-compat-headers
curl-dev
flac-dev
+ flite-dev
gnutls-dev
+ ilbc-dev
ldns-dev
lame-dev
libedit-dev
libjpeg-turbo-dev
libogg-dev
libpri-dev
+ libshout-dev
+ libsndfile-dev
libvorbis-dev
linux-headers
lua5.2-dev
+ mpg123-dev
ncurses-dev
net-snmp-dev
openssl-dev
@@ -38,6 +44,7 @@ makedepends="bash
sqlite-dev
unixodbc-dev
util-linux-dev
+ xmlrpc-c-dev
zlib-dev
autoconf automake libtool
@@ -53,25 +60,14 @@ _lame="lame-3.98.4.tar.gz"
_libshout="libshout-2.2.2.tar.gz"
_mpg123="mpg123-1.13.2.tar.gz"
_libsources="
- freeswitch-$_json_c::http://files.freeswitch.org/downloads/libs/$_json_c
- freeswitch-$_flite::http://files.freeswitch.org/downloads/libs/$_flite
- freeswitch-$_lame::http://files.freeswitch.org/downloads/libs/$_lame
- freeswitch-$_libshout::http://files.freeswitch.org/downloads/libs/$_libshout
- freeswitch-$_mpg123::http://files.freeswitch.org/downloads/libs/$_mpg123
"
-source="http://files.freeswitch.org/$pkgname-$pkgver.tar.xz
+source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
$_libsources
getlib.patch
modules.conf
freeswitch.confd
freeswitch.initd
- libshout-disable-examples.patch
- freeswitch-mod_shout-textrels.patch
- system-lame.patch
- 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
- fix-voicemail-greet-reset.patch
- 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -85,7 +81,6 @@ prepare() {
cd "$_builddir"
for i in $source; do
case $i in
- libshout-disable-examples.patch) msg $i; cd "$srcdir"; patch -p0 -i "$srcdir"/$i || return 1;;
*.patch) msg $i; cd "$_builddir"; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
@@ -95,14 +90,6 @@ prepare() {
build() {
cd "$_builddir"
-
- # remove Werror
- sed -i -e 's/-Werror/-Wall/g' configure
-
- # i think our max cmd len is 32768
- # by specifying it here we save our selves from some CPU cycles
- export lt_cv_sys_max_cmd_len=8192
-
cp -f "$srcdir/modules.conf" modules.conf || return 1
CFLAGS="-Wno-unused-but-set-variable" ./configure \
@@ -110,6 +97,8 @@ build() {
--host=$CHOST \
--prefix=/usr \
--enable-fhs \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
--with-scriptdir=/etc/freeswitch/scripts \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -118,6 +107,7 @@ build() {
--disable-debug \
--enable-core-pgsql-support \
--enable-system-lua \
+ --enable-system-xmlrpc-c \
|| return 1
# first build libfreeswitch (in parallel)
@@ -211,51 +201,18 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="2c40823068203cfd1b96ae10503a9783 freeswitch-1.4.20.tar.xz
-4653b3b9c568bb9c782178abfaac128d freeswitch-json-c-0.9.tar.gz
-645db96ffc296cbb6d37f231cc1cc6b2 freeswitch-flite-2.0.0-release.tar.bz2
-8e9866ad6b570c6c95c8cba48060473f freeswitch-lame-3.98.4.tar.gz
-e409b006b5dad6d8668c3e429bf20159 freeswitch-libshout-2.2.2.tar.gz
-452fd875cb5e4d16f77c757371836fff freeswitch-mpg123-1.13.2.tar.gz
+md5sums="6e7fbf77be0fcccecf12284437e6cbda freeswitch-1.6.2.tar.xz
1e7f335ee00f589825ecc9affa779346 getlib.patch
-0eb382f73ed393f28b8a797ebbfa608b modules.conf
+d67ac9b54cc062ffff7c2b4d5631c3bd modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-3b0bf4847a61afa28229b58763f4c400 freeswitch.initd
-90b133b14a42c86d53d5e54dcbfbaf58 libshout-disable-examples.patch
-4cd4923463c89bed053e6295b5a4ec40 freeswitch-mod_shout-textrels.patch
-6a6c4aba80e99c236ef712b17f3cdd01 system-lame.patch
-0d9dc1f09b6c150622bc59cdba86b89c 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
-ca7ef52c092f66b06dbf76dce2d05eb3 fix-voicemail-greet-reset.patch
-e775523c5f530e7ec7a72507637d6c2d 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
-sha256sums="46bb7e7f83dd616f268085c7e36fd45b48c3f02821dbea110211f0e10da16b09 freeswitch-1.4.20.tar.xz
-816fb2d4baab09e2f51a7c1be75bc9e03ed09d4cf3c2cd03c183f433bb9b565f freeswitch-json-c-0.9.tar.gz
-678c3860fd539402b5d1699b921239072af6acb4e72dc4720494112807cae411 freeswitch-flite-2.0.0-release.tar.bz2
-ac3144c76617223a9be4aaa3e28a66b51bcab28141050c3af04cb06836f772c8 freeswitch-lame-3.98.4.tar.gz
-38701125cb0e0349f4394dd3254d6037eeb8af0747c0942ff433ffbcd48d2367 freeswitch-libshout-2.2.2.tar.gz
-b3a855acc96e0061a0c2b1162e8aff80b6b1a03849e3756786db2fcacfc9a9bd freeswitch-mpg123-1.13.2.tar.gz
+3b0bf4847a61afa28229b58763f4c400 freeswitch.initd"
+sha256sums="cf26f491469d2f744fb48ba0a7e25cefd96305e0ef385eda09fca82c096bb48f freeswitch-1.6.2.tar.xz
ab437c92149b6fc88bc2fc8a228d6a5f8af574e2c90469a6dc4c753d13972c34 getlib.patch
-f83f9680d243eb254bf045571f971a6c5cf716367444cd48ed26d4c3367f4c41 modules.conf
+12084b329ed10b109fe1487e9a4e378dea8c0d85a6ff9c3533245b37019e5af3 modules.conf
846a29a361ef6eecd77876963b5c0133699c40fa8b34c68df42d5f8a1a1915b1 freeswitch.confd
-aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432 freeswitch.initd
-db0d3c252b5664ecb071bcf6868eff77c85dd7943a63fcfcac7e19db6a0ff61f libshout-disable-examples.patch
-be1009327de615f04956ba0b0f44183f31c263e380af8027f94b976a84bcb09a freeswitch-mod_shout-textrels.patch
-11b107ca8632bb9c8fcb2aedfcfb421af24929aace4f56c34d4e701eb410e190 system-lame.patch
-1e3c67da8c17130d872213c718b8113f7cb08e67e166a91e2507facd8cd15b58 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
-5581489ce522d8c46f9bfccb8ab2c581cc4cd6c2da9a8d9ed80ebfe8cbd59b70 fix-voicemail-greet-reset.patch
-eaa1c119628e507786884e0377ed04da0a7648ee4597bdb2c59d634a8c3eb903 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
-sha512sums="f7f3209ed5c6de4b0c92edd772d12f7a62342289db142d05f7559b0053f9e4e17d65f1d7680abdbda1743a4b30764bc13941c24edb9541265d2c08f99cbe0a64 freeswitch-1.4.20.tar.xz
-38b8729275bbfebaee783e703d19481f3d32b50cfdeb338644b8db2742573ea025702c789b5ce8d5067dcde23c5a16b46231eaadf0b9c5dbff392d410912c772 freeswitch-json-c-0.9.tar.gz
-e2b353721d0316fbd7948f90f9c9561d080eebd50e8dd0449a9c803ffbdb060a469385fadd63f535ade8d627cba37928d8e72ac61d5bcf98f73ca5ebb66549f8 freeswitch-flite-2.0.0-release.tar.bz2
-cf6cff914c06c2d65470c577eed2bfa226e9017cdfd26aa3e95c3b3b76c40568151ca223327859d6dacb982c80c06b672ba4e9f32ce1e452363c95126edb301b freeswitch-lame-3.98.4.tar.gz
-d517d1d6a79dfd4819c42603faafc051c69270831f4894c01f6bd38e877eb008f8458534857641fd8d653fd437fb41ee1c558ff2a76339c3a8a579f4d5a26baf freeswitch-libshout-2.2.2.tar.gz
-1940b6bf1c7167a7718ac0972e9c8cf9a49cf8c7a4a062052d00ead282cf4ae63214bfc317f2ccb424f6f3f26c602e91300d45635ba2d4f8da992c94b3ed0885 freeswitch-mpg123-1.13.2.tar.gz
+aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432 freeswitch.initd"
+sha512sums="b85ebbdc0f4111f76e798b91d23d05b63966fe8ac273bc2581857c1b9b810f970f25fd244ce40884d4939e835c72d7700448ea663a4f2650eb34d67325aa0517 freeswitch-1.6.2.tar.xz
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
-6330e47cd3dcfdb4f5c99e91c9c725c7c8aa4f1691d83817d7600e510b5a586f3312bab84df3766448bbdab78cd1feebecf64b8280626b3f751f6e787f145e23 modules.conf
+89faf3a64797b339f2f03ed8bf3e02a17c03896e6c0ca6dbb710a8d7f42ad06299bc5975add6bfd9d038c2aa76239a2f5d83530e8346d24d8f6716fc2fe36c66 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
-643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd
-91a6d7c8456de65855930b371f568f0230c28422e667453aa48fababd185b47677c06ff0c79f94c2a02182439b012d48cb54548cbde3d12b8d0e1ffbb9b229cc libshout-disable-examples.patch
-5f085254ca9f5dc196afd39fc55e083b1998e776d9de2428e5657d99077526c33c1fc13f12432598184ce63138447fed7c318c384b743681703f5682dc8e1e50 freeswitch-mod_shout-textrels.patch
-398dd0f2665415ff40348dc94d26ec7008fb59ec033f9d2c64dc1aa01071021f83f47954e95efc58c4033f22bb6da159e83e3b0d36b99189d5e7535ed6ae70bd system-lame.patch
-342abf9f41b7d957759228d5d81aceba1f0862871e29e55f7b46b45001e77e40bc577020fc0f3e693645f39c54a69a13d16ad17776bc49b1f0f05a244c98d5f8 0001-FS-7969-resolve-Freeswitch-segfaults-due-to-pthread_.patch
-2cceb0d8a108499467047874a312046e17b252c3b5c0fa722069750345a9bd62fdfd6c4d13bc7fa7b1bd7be3b4b783f649f78995863c509949ead35a2270d704 fix-voicemail-greet-reset.patch
-f1edca43322a767b28f86f58921584121254cd3dea8a4f03f120794eb82ebbcc7161b6d2c2a139e7ca69491f345462f2a5e5fbaffd45883ba2024e453e17c69d 0001-FS-8131-mod_voicemail-fix-disallowed-empty-password-.patch"
+643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd"
diff --git a/main/freeswitch/fix-voicemail-greet-reset.patch b/main/freeswitch/fix-voicemail-greet-reset.patch
deleted file mode 100644
index 10ab99a26e..0000000000
--- a/main/freeswitch/fix-voicemail-greet-reset.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/src/mod/applications/mod_voicemail/mod_voicemail.c b/src/mod/applications/mod_voicemail/mod_voicemail.c
-index 624bb70..7aa96b7 100644
---- a/src/mod/applications/mod_voicemail/mod_voicemail.c
-+++ b/src/mod/applications/mod_voicemail/mod_voicemail.c
-@@ -2214,10 +2214,10 @@ static void voicemail_check_main(switch_core_session_t *session, vm_profile_t *p
-
-
- num = atoi(input);
-- file_path = switch_mprintf("%s%sgreeting_%d.%s", dir_path, SWITCH_PATH_SEPARATOR, num, profile->file_ext);
-- if (num < 1 || num > VM_MAX_GREETINGS) {
-+ if (num < 0 || num > VM_MAX_GREETINGS) {
- status = SWITCH_STATUS_FALSE;
-- } else {
-+ } else if (num > 0) {
-+ file_path = switch_mprintf("%s%sgreeting_%d.%s", dir_path, SWITCH_PATH_SEPARATOR, num, profile->file_ext);
- switch_file_handle_t fh = { 0 };
- memset(&fh, 0, sizeof(fh));
- greeting_args.input_callback = control_playback;
-@@ -2234,15 +2234,25 @@ static void voicemail_check_main(switch_core_session_t *session, vm_profile_t *p
- switch_event_t *params;
-
- TRY_CODE(switch_ivr_phrase_macro(session, VM_CHOOSE_GREETING_SELECTED_MACRO, input, NULL, NULL));
-- sql =
-- switch_mprintf("update voicemail_prefs set greeting_path='%s' where username='%s' and domain='%s'", file_path, myid,
-+ if (file_path == NULL) {
-+ sql =
-+ switch_mprintf("update voicemail_prefs set greeting_path=NULL where username='%s' and domain='%s'", myid,
- domain_name);
-+ } else {
-+ sql =
-+ switch_mprintf("update voicemail_prefs set greeting_path='%s' where username='%s' and domain='%s'",
-+ file_path, myid, domain_name);
-+ }
- vm_execute_sql(profile, sql, profile->mutex);
- switch_safe_free(sql);
-
- switch_event_create_subclass(&params, SWITCH_EVENT_CUSTOM, VM_EVENT_MAINT);
-- switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Action", "change-greeting");
-- switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Greeting-Path", file_path);
-+ if (file_path == NULL) {
-+ switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Action", "remove-greeting");
-+ } else {
-+ switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Action", "change-greeting");
-+ switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Greeting-Path", file_path);
-+ }
- switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-User", myid);
- switch_event_add_header_string(params, SWITCH_STACK_BOTTOM, "VM-Domain", domain_name);
- switch_channel_event_set_data(channel, params);
diff --git a/main/freeswitch/freeswitch-mod_shout-textrels.patch b/main/freeswitch/freeswitch-mod_shout-textrels.patch
deleted file mode 100644
index 368245a01e..0000000000
--- a/main/freeswitch/freeswitch-mod_shout-textrels.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/mod/formats/mod_shout/Makefile.in.orig
-+++ b/src/mod/formats/mod_shout/Makefile.in
-@@ -772,7 +772,7 @@
-
- $(MPG123_BUILDDIR)/Makefile: $(MPG123_DIR)
- mkdir -p $(MPG123_BUILDDIR)
-- cd $(MPG123_BUILDDIR) && $(DEFAULT_VARS) $(MPG123_DIR)/configure $(DEFAULT_ARGS) --disable-shared --with-pic --srcdir=$(MPG123_DIR) CPPFLAGS= LDFLAGS=
-+ cd $(MPG123_BUILDDIR) && $(DEFAULT_VARS) $(MPG123_DIR)/configure $(DEFAULT_ARGS) --disable-shared --with-cpu=i386_fpu --with-pic --srcdir=$(MPG123_DIR) CPPFLAGS= LDFLAGS=
- $(TOUCH_TARGET)
-
- $(MPG123LA): $(MPG123_BUILDDIR)/Makefile
diff --git a/main/freeswitch/libshout-disable-examples.patch b/main/freeswitch/libshout-disable-examples.patch
deleted file mode 100644
index 121de35559..0000000000
--- a/main/freeswitch/libshout-disable-examples.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- libshout-2.2.2/Makefile.in
-+++ libshout-2.2.2/Makefile.in
-@@ -246,14 +246,14 @@
- target_alias = @target_alias@
- AUTOMAKE_OPTIONS = 1.6 foreign
- ACLOCAL_AMFLAGS = -I m4
--SUBDIRS = include src examples debian doc win32
-+SUBDIRS = include src debian doc win32
- EXTRA_DIST = INSTALL m4/shout.m4 m4/ac_config_libconfig_in.m4 m4/acx_pthread.m4 \
- m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
- m4/xiph_types.m4
-
- DISTCLEANFILES = shout-config.in
- docdir = $(datadir)/doc/$(PACKAGE)
--doc_DATA = COPYING NEWS README examples/example.c examples/nonblocking.c
-+doc_DATA = COPYING NEWS README
- m4datadir = $(datadir)/aclocal
- m4data_DATA = m4/shout.m4
- @HAVE_PKGCONFIG_TRUE@pkgconfigdir = $(libdir)/pkgconfig
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index eef8d52be7..ada18e5596 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -18,7 +18,7 @@ applications/mod_esf
applications/mod_expr
applications/mod_fifo
#applications/mod_fsk
-applications/mod_fsv
+#applications/mod_fsv
applications/mod_hash
applications/mod_httapi
#applications/mod_http_cache
@@ -28,7 +28,7 @@ applications/mod_httapi
#applications/mod_mongo
#applications/mod_nibblebill
#applications/mod_osp
-#applications/mod_redis
+applications/mod_redis
#applications/mod_rss
applications/mod_sms
#applications/mod_snapshot
@@ -50,7 +50,7 @@ asr_tts/mod_flite
#asr_tts/mod_unimrcp
codecs/mod_amr
#codecs/mod_amrwb
-codecs/mod_bv
+#codecs/mod_bv
#codecs/mod_celt
#codecs/mod_codec2
#codecs/mod_com_g729
@@ -64,7 +64,7 @@ codecs/mod_ilbc
#codecs/mod_opus
codecs/mod_sangoma_codec
#codecs/mod_silk
-codecs/mod_siren
+#codecs/mod_siren
codecs/mod_speex
dialplans/mod_dialplan_asterisk
#dialplans/mod_dialplan_directory
diff --git a/main/freeswitch/musl-fixes.patch b/main/freeswitch/musl-fixes.patch
deleted file mode 100644
index eff7684d9f..0000000000
--- a/main/freeswitch/musl-fixes.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-diff --git a/libs/libscgi/src/include/scgi.h b/libs/libscgi/src/include/scgi.h
-index cc6b3c0..332a071 100644
---- a/libs/libscgi/src/include/scgi.h
-+++ b/libs/libscgi/src/include/scgi.h
-@@ -116,7 +116,7 @@ typedef int scgi_filehandle_t;
- #include <sys/types.h>
- #include <sys/select.h>
- #include <netinet/tcp.h>
--#include <sys/signal.h>
-+#include <signal.h>
- #include <unistd.h>
- #include <ctype.h>
- #endif
-diff --git a/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_os_nw.h b/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_os_nw.h
-index ed6cf38..75b73b0 100644
---- a/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_os_nw.h
-+++ b/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_os_nw.h
-@@ -58,7 +58,7 @@
- #endif
-
- #if SU_HAVE_POLL
--#include <sys/poll.h>
-+#include <poll.h>
- #endif
-
- SOFIA_BEGIN_DECLS
-diff --git a/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_wait.h b/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_wait.h
-index ad67723..7beaae6 100644
---- a/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_wait.h
-+++ b/libs/sofia-sip/libsofia-sip-ua/su/sofia-sip/su_wait.h
-@@ -47,7 +47,7 @@
- #endif
-
- #if SU_HAVE_POLL
--#include <sys/poll.h>
-+#include <poll.h>
- #endif
-
- SOFIA_BEGIN_DECLS
-diff --git a/libs/spandsp/src/spandsp/private/timezone.h b/libs/spandsp/src/spandsp/private/timezone.h
-index 87c6797..b2397cf 100644
---- a/libs/spandsp/src/spandsp/private/timezone.h
-+++ b/libs/spandsp/src/spandsp/private/timezone.h
-@@ -30,7 +30,7 @@
-
- #define TZ_MAX_LEAPS 50 /* Maximum number of leap second corrections */
-
--#define TZNAME_MAX 255
-+#define SPANDSP_TZNAME_MAX 255
-
- /* The TZ_MAX_TIMES value below is enough to handle a bit more than a
- * year's worth of solar time (corrected daily to the nearest second) or
-@@ -74,14 +74,14 @@ struct tz_state_s
- time_t ats[TZ_MAX_TIMES];
- uint8_t types[TZ_MAX_TIMES];
- struct tz_ttinfo_s ttis[TZ_MAX_TYPES];
-- char chars[TZ_BIGGEST(TZ_MAX_CHARS + 1, (2*(TZNAME_MAX + 1)))];
-+ char chars[TZ_BIGGEST(TZ_MAX_CHARS + 1, (2*(SPANDSP_TZNAME_MAX + 1)))];
- struct tz_lsinfo_s lsis[TZ_MAX_LEAPS];
- };
-
- struct tz_s
- {
- struct tz_state_s state;
-- char lcl_tzname[TZNAME_MAX + 1];
-+ char lcl_tzname[SPANDSP_TZNAME_MAX + 1];
- int lcl_is_set;
- const char *tzname[2];
- };
-diff --git a/src/mod/applications/mod_spandsp/mod_spandsp_modem.h b/src/mod/applications/mod_spandsp/mod_spandsp_modem.h
-index 8d41cd2..02dc074 100644
---- a/src/mod/applications/mod_spandsp/mod_spandsp_modem.h
-+++ b/src/mod/applications/mod_spandsp/mod_spandsp_modem.h
-@@ -89,7 +89,7 @@
- (uint64_t)bswap_32((uint32_t)((value) >> 32)))
- #endif
- #include <sys/time.h>
--#include <sys/signal.h>
-+#include <signal.h>
- #endif
- #include <sys/types.h>
- #include <sys/stat.h>
diff --git a/main/freeswitch/system-lame.patch b/main/freeswitch/system-lame.patch
deleted file mode 100644
index 5c710c3929..0000000000
--- a/main/freeswitch/system-lame.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./src/mod/formats/mod_shout/Makefile.in.orig
-+++ ./src/mod/formats/mod_shout/Makefile.in
-@@ -111,7 +111,7 @@
- am__installdirs = "$(DESTDIR)$(moddir)"
- LTLIBRARIES = $(mod_LTLIBRARIES)
- mod_shout_la_DEPENDENCIES = $(switch_builddir)/libfreeswitch.la \
-- $(LAMELA) $(SHOUTLA) $(MPG123LA)
-+ $(SHOUTLA) $(MPG123LA)
- am_mod_shout_la_OBJECTS = mod_shout_la-mod_shout.lo
- mod_shout_la_OBJECTS = $(am_mod_shout_la_OBJECTS)
- AM_V_lt = $(am__v_lt_@AM_V@)
-@@ -434,10 +434,10 @@
- mod_LTLIBRARIES = mod_shout.la
- mod_shout_la_SOURCES = mod_shout.c
- mod_shout_la_CFLAGS = $(AM_CFLAGS)
--mod_shout_la_CPPFLAGS = $(CURL_CFLAGS) $(AM_CPPFLAGS) -I$(SHOUT_DIR)/include -I$(LAME_DIR)/include -I$(MPG123_DIR)/src -I$(MPG123_BUILDDIR)/src -I$(SHOUT_BUILDDIR)/include
--mod_shout_la_LIBADD = $(switch_builddir)/libfreeswitch.la $(LAMELA) $(SHOUTLA) $(MPG123LA)
--mod_shout_la_LDFLAGS = $(CURL_LIBS) -avoid-version -module -no-undefined -shared `cat $(SHOUT_BUILDDIR)/Makefile | grep SPEEX_LIBS | sed -e 's|^SPEEX_LIBS =||'` `cat $(SHOUTLA) | grep dependency_libs | sed -e 's|^dependency_libs=||' | sed -e "s|'||g"`
--BUILT_SOURCES = $(LAMELA) $(SHOUTLA) $(MPG123LA)
-+mod_shout_la_CPPFLAGS = $(CURL_CFLAGS) $(AM_CPPFLAGS) -I$(SHOUT_DIR)/include -I/usr/include/lame -I$(MPG123_DIR)/src -I$(MPG123_BUILDDIR)/src -I$(SHOUT_BUILDDIR)/include
-+mod_shout_la_LIBADD = $(switch_builddir)/libfreeswitch.la $(SHOUTLA) $(MPG123LA)
-+mod_shout_la_LDFLAGS = $(CURL_LIBS) -lmp3lame -avoid-version -module -no-undefined -shared `cat $(SHOUT_BUILDDIR)/Makefile | grep SPEEX_LIBS | sed -e 's|^SPEEX_LIBS =||'` `cat $(SHOUTLA) | grep dependency_libs | sed -e 's|^dependency_libs=||' | sed -e "s|'||g"`
-+BUILT_SOURCES = $(SHOUTLA) $(MPG123LA)
- all: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) all-am
-