aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorL. Tosser <loic.tosser@aswat-telecom.com>2016-01-19 12:38:27 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-01-19 12:58:32 +0000
commit09022fe878d7e8536270386993bc4e4d9c038138 (patch)
treef8eb6209f49c06bb60eadcabd48398a316b4294e /main/freeswitch
parent34be128a47762c967c596f7c2f739fa27b861379 (diff)
downloadaports-09022fe878d7e8536270386993bc4e4d9c038138.tar.bz2
aports-09022fe878d7e8536270386993bc4e4d9c038138.tar.xz
main/freeswitch: upgrade to 1.6.6, remove patches & add modules
* Upgrade to Freeswtich 1.6.6 * Remove useless patches (integrated in Freeswitch 1.6.6) * Add applications/mod_blacklist endpoints/mod_rtc endpoints/mod_skinny endpoints/mod_verto * Add patch for mod_verto
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch39
-rw-r--r--main/freeswitch/0002-FS-verto-bswap_64.patch12
-rw-r--r--main/freeswitch/APKBUILD34
-rw-r--r--main/freeswitch/FS-8612-calls-crash-due-to-read-codec-leak.patch12
-rw-r--r--main/freeswitch/modules.conf6
5 files changed, 31 insertions, 72 deletions
diff --git a/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch b/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
deleted file mode 100644
index f11c2d1657..0000000000
--- a/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From de06bf086bdaa442cba0d44bde65265eb4d7fc14 Mon Sep 17 00:00:00 2001
-From: Stanislav Sinyagin <ssinyagin@k-open.com>
-Date: Mon, 9 Nov 2015 21:54:00 +0000
-Subject: [PATCH] FS-8427 Incompatible type for %ld in prinrtf
-
----
- src/mod/applications/mod_av/avcodec.c | 2 +-
- src/mod/endpoints/mod_rtmp/rtmp_tcp.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/mod/applications/mod_av/avcodec.c b/src/mod/applications/mod_av/avcodec.c
-index 4d4cb24..199f760 100644
---- a/src/mod/applications/mod_av/avcodec.c
-+++ b/src/mod/applications/mod_av/avcodec.c
-@@ -539,7 +539,7 @@ static void fs_rtp_parse_h263_rfc2190(h264_codec_context_t *context, AVPacket *p
- mb_info_pos++;
- } else {
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_WARNING,
-- "Unable to split H263 packet! mb_info_pos=%d mb_info_count=%d pos=%d max=%ld\n", mb_info_pos, mb_info_count, pos, end - buf_base);
-+ "Unable to split H263 packet! mb_info_pos=%d mb_info_count=%d pos=%d max=%"SWITCH_SIZE_T_FMT"\n", mb_info_pos, mb_info_count, pos, (switch_size_t)(end - buf_base));
- }
- } else {
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_ERROR, "Should Not Happen!!! mb_info_pos=%d mb_info_count=%d mb_info_size=%d\n", mb_info_pos, mb_info_count, mb_info_size);
-diff --git a/src/mod/endpoints/mod_rtmp/rtmp_tcp.c b/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
-index e716272..4389cef 100644
---- a/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
-+++ b/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
-@@ -136,7 +136,7 @@ again:
- break;
- }
-
-- if (*len != orig_len) switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "sent %ld of %ld\n", *len, orig_len);
-+ if (*len != orig_len) switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "sent %"SWITCH_SIZE_T_FMT" of %"SWITCH_SIZE_T_FMT"\n", *len, orig_len);
- buf += *len;
- remaining -= *len;
- *len = remaining;
---
-2.6.3
-
diff --git a/main/freeswitch/0002-FS-verto-bswap_64.patch b/main/freeswitch/0002-FS-verto-bswap_64.patch
new file mode 100644
index 0000000000..0cee934c79
--- /dev/null
+++ b/main/freeswitch/0002-FS-verto-bswap_64.patch
@@ -0,0 +1,12 @@
+--- a/src/mod/endpoints/mod_verto/ws.h
++++ b/src/mod/endpoints/mod_verto/ws.h
+@@ -36,6 +36,9 @@
+ ((x>>40) & 0x000000000000FF00) | \
+ (x<<56)
+ #endif
++#ifndef __bswap_64
++#include <byteswap.h>
++#endif
+ #ifdef _MSC_VER
+ #ifndef strncasecmp
+ #define strncasecmp _strnicmp \ No newline at end of file
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index c296390dbf..cf2efeb571 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-pkgver=1.6.2
-pkgrel=5
+pkgver=1.6.6
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -63,12 +63,11 @@ _libsources="
source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
$_libsources
- 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
+ 0002-FS-verto-bswap_64.patch
getlib.patch
modules.conf
freeswitch.confd
freeswitch.initd
- FS-8612-calls-crash-due-to-read-codec-leak.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -202,24 +201,21 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="6e7fbf77be0fcccecf12284437e6cbda freeswitch-1.6.2.tar.xz
-80d7f0aa84278f5236805753ec3e3f1f 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
+md5sums="9a2383a7f321ab0f8fb1e7a212081a17 freeswitch-1.6.6.tar.xz
+1c08df4cf4ef737e6cc6945f9462f08e 0002-FS-verto-bswap_64.patch
1e7f335ee00f589825ecc9affa779346 getlib.patch
-f99cb4857c5b79fc6646855fe74527c7 modules.conf
+45bbdea4215ebcd6dbeb3ae6540a14dc modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-3b0bf4847a61afa28229b58763f4c400 freeswitch.initd
-078925cba3d5c6b70071acfb591d3fc8 FS-8612-calls-crash-due-to-read-codec-leak.patch"
-sha256sums="cf26f491469d2f744fb48ba0a7e25cefd96305e0ef385eda09fca82c096bb48f freeswitch-1.6.2.tar.xz
-cc8e509c7aab120eb74a23b2c2a8c64e00497377ea9fc5572559c3361ddfefec 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
+3b0bf4847a61afa28229b58763f4c400 freeswitch.initd"
+sha256sums="397b9c63c2c1f7008a2cc269f2e0e9a935d862b3fb074a6044819bcaea02ebc0 freeswitch-1.6.6.tar.xz
+2685eb17fcd4510e46bb1d88be5550c3cb7b08f2acccfb41b2c680480c91b63e 0002-FS-verto-bswap_64.patch
ab437c92149b6fc88bc2fc8a228d6a5f8af574e2c90469a6dc4c753d13972c34 getlib.patch
-212f6b4e8463cf2e1266582479f965fd96416c45cda0b016d0becd6e71fec015 modules.conf
+5e4fa321a85650b446d54e33926ebea4fd76a6816f51612793cf9c14616c823b modules.conf
846a29a361ef6eecd77876963b5c0133699c40fa8b34c68df42d5f8a1a1915b1 freeswitch.confd
-aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432 freeswitch.initd
-cf40b3845a35c0de97c71b4fce2a49ad8d08d95a649dda30fcacb28e8a9be872 FS-8612-calls-crash-due-to-read-codec-leak.patch"
-sha512sums="b85ebbdc0f4111f76e798b91d23d05b63966fe8ac273bc2581857c1b9b810f970f25fd244ce40884d4939e835c72d7700448ea663a4f2650eb34d67325aa0517 freeswitch-1.6.2.tar.xz
-5faaf44f36430ad18769b36e45571320a139e853f6adec2ed0f2c16fffdcd0461a30a674dbae18edc0701a5c1e76f5ddb30962960421db6b103e2f220b9482d0 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
+aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432 freeswitch.initd"
+sha512sums="1e16904084f8ada7cfea27ed3222eb660a14f08b12e6b4ddc5db2893b690936bf4d945b94d9f6eb1893e62124858c39b658c5c5ac425ad064db69d44f57179a9 freeswitch-1.6.6.tar.xz
+5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8 0002-FS-verto-bswap_64.patch
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
-e5027d504c63a2f51419c8b071f4a7d3499177cf2bfd8782e039137475e20910cf3f654848e2d86ecdbcba147592ebdc988ee9083272d7c88f60322bcefa7a6a modules.conf
+66921b330ace8fc330b1f58c0272325861f0a7bcb3a0f184b534da624beb7ef771065571b58866dd8a5891f1d1f4d12898beb378582b57e425bad65d11d2f281 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
-643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd
-f951a6e065f638d3259f4897702dcf240d84a7b1204a0e7f51d60ab625e8eed74421c58bc58f08e1cd72db339e8166726545a6001a18e6cd56d54e4d57d2f46d FS-8612-calls-crash-due-to-read-codec-leak.patch"
+643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd"
diff --git a/main/freeswitch/FS-8612-calls-crash-due-to-read-codec-leak.patch b/main/freeswitch/FS-8612-calls-crash-due-to-read-codec-leak.patch
deleted file mode 100644
index 56abe1ce10..0000000000
--- a/main/freeswitch/FS-8612-calls-crash-due-to-read-codec-leak.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/switch_ivr_originate.c b/src/switch_ivr_originate.c
-index c65b80b..6b03c17 100644
---- a/src/switch_ivr_originate.c
-+++ b/src/switch_ivr_originate.c
-@@ -1863,6 +1863,7 @@ static void *SWITCH_THREAD_FUNC early_thread_run(switch_thread_t *thread, void *
- if (!session) continue;
-
- if (switch_core_codec_ready((&read_codecs[i]))) {
-+ switch_core_session_set_read_codec(session, NULL);
- switch_core_codec_destroy(&read_codecs[i]);
- }
-
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index 03e4555fb1..bb6c89c306 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -1,6 +1,6 @@
#applications/mod_abstraction
#applications/mod_avmd
-#applications/mod_blacklist
+applications/mod_blacklist
applications/mod_callcenter
#applications/mod_cidlookup
applications/mod_cluechoo
@@ -78,10 +78,12 @@ endpoints/mod_dingaling
endpoints/mod_loopback
#endpoints/mod_opal
endpoints/mod_portaudio
+endpoints/mod_rtc
endpoints/mod_rtmp
-#endpoints/mod_skinny
+endpoints/mod_skinny
#endpoints/mod_skypopen
endpoints/mod_sofia
+endpoints/mod_verto
event_handlers/mod_cdr_csv
event_handlers/mod_json_cdr
#event_handlers/mod_cdr_mongodb