aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-29 17:00:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:09 +0000
commit0ddc3765e529787e59084f84b6006eb2c7b22a21 (patch)
tree05e57db3e0d255cba6e725d2f175a02ed9d9d333 /main/freeswitch
parent3ac2734f08547043e723b6f020fd0033d70db413 (diff)
downloadaports-0ddc3765e529787e59084f84b6006eb2c7b22a21.tar.bz2
aports-0ddc3765e529787e59084f84b6006eb2c7b22a21.tar.xz
main/freeswitch: upgrade to 1.8.2
fixes #9548
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch34
-rw-r--r--main/freeswitch/0001-mod_avmd-use-posix-isinf.patch18
-rw-r--r--main/freeswitch/APKBUILD15
-rw-r--r--main/freeswitch/pcre.patch13
-rw-r--r--main/freeswitch/sofia-sip-libressl.patch13
5 files changed, 4 insertions, 89 deletions
diff --git a/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch b/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
deleted file mode 100644
index 3de8c54572..0000000000
--- a/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 9d96741f56b7f663fd1b0ad625b4b7042832ebca Mon Sep 17 00:00:00 2001
-From: Italo Rossi <italorossib@gmail.com>
-Date: Mon, 6 Nov 2017 10:35:36 -0300
-Subject: [PATCH] FS-10774 - [switch_pgsql] Fix build for PostgreSQL/libpq 10
-
----
- src/switch_pgsql.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/switch_pgsql.c b/src/switch_pgsql.c
-index 7928624270..f3411361fd 100644
---- a/src/switch_pgsql.c
-+++ b/src/switch_pgsql.c
-@@ -386,7 +386,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
- *result_out = res;
- res->status = PQresultStatus(res->result);
- switch(res->status) {
--#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 2
-+#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 2) || POSTGRESQL_MAJOR_VERSION > 9
- case PGRES_SINGLE_TUPLE:
- /* Added in PostgreSQL 9.2 */
- #endif
-@@ -397,7 +397,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
- res->cols = PQnfields(res->result);
- }
- break;
--#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 1
-+#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 1) || POSTGRESQL_MAJOR_VERSION > 9
- case PGRES_COPY_BOTH:
- /* Added in PostgreSQL 9.1 */
- #endif
---
-2.15.0
-
diff --git a/main/freeswitch/0001-mod_avmd-use-posix-isinf.patch b/main/freeswitch/0001-mod_avmd-use-posix-isinf.patch
deleted file mode 100644
index afbf3696f8..0000000000
--- a/main/freeswitch/0001-mod_avmd-use-posix-isinf.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/src/mod/applications/mod_avmd/avmd_desa2_tweaked.c b/src/mod/applications/mod_avmd/avmd_desa2_tweaked.c
-index 6bf0b41..7ef31f7 100644
---- a/src/mod/applications/mod_avmd/avmd_desa2_tweaked.c
-+++ b/src/mod/applications/mod_avmd/avmd_desa2_tweaked.c
-@@ -16,10 +16,9 @@
- #define ISNAN(x) (!!(_isnan(x)))
- #define ISINF(x) (isinf(x))
- #else
-- int __isnan(double);
-- int __isinf(double);
-- #define ISNAN(x) (__isnan(x))
-- #define ISINF(x) (__isinf(x))
-+ #include <math.h>
-+ #define ISNAN(x) (isnan(x))
-+ #define ISINF(x) (isinf(x))
- #endif
-
- #include "avmd_buffer.h"
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 3163d0c9b1..3e48b49ef8 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-pkgver=1.6.20
+pkgver=1.8.2
pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
@@ -26,7 +26,7 @@ makedepends="
libjpeg-turbo-dev
libogg-dev
libpri-dev
- libressl-dev
+ openssl-dev
libshout-dev
libsndfile-dev
libvorbis-dev
@@ -44,6 +44,7 @@ makedepends="
speex-dev
speexdsp-dev
sqlite-dev
+ tiff-dev
unixodbc-dev
util-linux-dev
xmlrpc-c-dev
@@ -61,14 +62,10 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-flite $pkgname-timezones::noarch
$pkgname-snmp $pkgname-pgsql $pkgname-perl $pkgname-perlesl"
source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
- 0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
- 0001-mod_avmd-use-posix-isinf.patch
0001-sofia-sip-byte-order.patch
0002-FS-verto-bswap_64.patch
- sofia-sip-libressl.patch
getlib.patch
configure-lua53.patch
- pcre.patch
modules.conf
freeswitch.confd
freeswitch.initd
@@ -216,15 +213,11 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-sha512sums="f3841b119925b5b82acca67cfa9bd3b47a19270d402ab9b4c1754117bc1ac331dc6d2e8ec386f3b3ed1b95ef9c6c4c6d7b438476dd378ab9b5384bbb4a42625f freeswitch-1.6.20.tar.xz
-db61d9a253105f7a1ef5f5c218b367a833f62a2e85e364e3971acc79f68037b0270c5b2f3e0909643278b6b93104ac8e59b323470aeef5f519c33b0289c0fcf3 0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
-482f9804b1c6e4120b4085885650c1b15006de629e475ca16d03feb314ce8816523b349217d10e80ba5a1aeead1090d8398bb05102bd9f2ebe673869286815ad 0001-mod_avmd-use-posix-isinf.patch
+sha512sums="30c5d2a151c95ab9c8c3252280fc25c7e7c5f7b57fb72b6a28b0673a3b9c96c9b6a5c1b85f0355122427e833e958ef86ba2960af3ee4cbcefd96f6019bc21a48 freeswitch-1.8.2.tar.xz
8a7ca31cc80524b02edc83af891a32af64dd7834ac14b1389112f2ce7fe06fe602d24509a299898f25e807dd0b88544aecb990bf4bd37ee1c7023ae58dacd28a 0001-sofia-sip-byte-order.patch
5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8 0002-FS-verto-bswap_64.patch
-5bb95dff04714bb94a8973a78cf46beb335e026e3b5e9bf6f6a5b60d94387dbe431a72c3bf37e553dc34a9773a3ea63e05b0b28d243a3ef97ad833c28c904f85 sofia-sip-libressl.patch
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
6ff9a31b0b69efe13208f96e55fcbaa8fc1fad220dede74df75c5259e72a6c1fede8145981f3e81547bdfc3a849cfa8f50297a6799d7874299fc3056910e54dc configure-lua53.patch
-3529080cddb2e7d0b6b39b2aaf3e0eb148469bb61e4722d6ce65853e0887df8d8c46b203f8f1f69726d289d0936a575d2da52b3885739666197eec0902dbf2df pcre.patch
6deecb303e765d44bdd970d5a7079c9dd9ce17d12056b68cd978a182a86b477b4a3c19d2f5a18f36199ca2e0594a3b84de521ab821e2f8c89f7449a3d7f21279 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd"
diff --git a/main/freeswitch/pcre.patch b/main/freeswitch/pcre.patch
deleted file mode 100644
index 54aafabdb9..0000000000
--- a/main/freeswitch/pcre.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/switch_regex.c b/src/switch_regex.c
-index 0531491..0435115 100644
---- a/src/switch_regex.c
-+++ b/src/switch_regex.c
-@@ -37,7 +37,7 @@ SWITCH_DECLARE(switch_regex_t *) switch_regex_compile(const char *pattern,
- int options, const char **errorptr, int *erroroffset, const unsigned char *tables)
- {
-
-- return pcre_compile(pattern, options, errorptr, erroroffset, tables);
-+ return (switch_regex_t *)pcre_compile(pattern, options, errorptr, erroroffset, tables);
-
- }
-
diff --git a/main/freeswitch/sofia-sip-libressl.patch b/main/freeswitch/sofia-sip-libressl.patch
deleted file mode 100644
index 17c3314a88..0000000000
--- a/main/freeswitch/sofia-sip-libressl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libs/sofia-sip/libsofia-sip-ua/tport/tport_tls.c b/libs/sofia-sip/libsofia-sip-ua/tport/tport_tls.c
-index c872336..3160f48 100644
---- a/libs/sofia-sip/libsofia-sip-ua/tport/tport_tls.c
-+++ b/libs/sofia-sip/libsofia-sip-ua/tport/tport_tls.c
-@@ -516,7 +516,7 @@ tls_t *tls_init_master(tls_issues_t *ti)
- if (ti->CAfile != NULL) {
- SSL_CTX_set_client_CA_list(tls->ctx,
- SSL_load_client_CA_file(ti->CAfile));
-- if (tls->ctx->client_CA == NULL)
-+ if (SSL_CTX_get_client_CA_list(tls->ctx) == NULL)
- tls_log_errors(3, "tls_init_master", 0);
- }
-