aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/ada-musl.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-11 08:22:04 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-11 08:23:48 +0200
commite7066615fbc87b519adb580a208a4905f992d401 (patch)
tree7c53676c8853641bd5ae76cca8209fb0779b408b /main/gcc/ada-musl.patch
parentd75e8d77a6d1c5df59f53a584d40a48b27d37ffc (diff)
downloadaports-e7066615fbc87b519adb580a208a4905f992d401.tar.bz2
aports-e7066615fbc87b519adb580a208a4905f992d401.tar.xz
main/gcc: fix muslgnueabi detection in ada bootstrap
Diffstat (limited to 'main/gcc/ada-musl.patch')
-rw-r--r--main/gcc/ada-musl.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/gcc/ada-musl.patch b/main/gcc/ada-musl.patch
index ebbe852225..1859faf35b 100644
--- a/main/gcc/ada-musl.patch
+++ b/main/gcc/ada-musl.patch
@@ -123,3 +123,14 @@ diff -ru gcc-4.9.2/gcc/ada/adaint.h gcc-4.9.2/gcc/ada/adaint.h
#endif
#if defined (_WIN32)
+--- gcc-4.9.2/gcc/ada/gcc-interface/Makefile.in.orig 2014-12-11 08:16:33.364902456 -0200
++++ gcc-4.9.2/gcc/ada/gcc-interface/Makefile.in 2014-12-11 08:16:51.998236755 -0200
+@@ -1948,7 +1948,7 @@
+ endif
+
+ # ARM linux, GNU eabi
+-ifeq ($(strip $(filter-out arm% linux-gnueabi%,$(target_cpu) $(target_os))),)
++ifeq ($(strip $(filter-out arm% linux-%gnueabi%,$(target_cpu) $(target_os))),)
+ LIBGNAT_TARGET_PAIRS = \
+ a-intnam.ads<a-intnam-linux.ads \
+ s-inmaop.adb<s-inmaop-posix.adb \