aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/gcc-4.8-build-args.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-12 21:36:19 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-07-12 21:37:40 +0000
commit47c71fbe7583fa29f604f5010bc6218d3f5856e3 (patch)
tree194cf51075fcbf5ddff60465c8f5cc6ecd697a21 /main/gcc/gcc-4.8-build-args.patch
parent752ebe08e01fecb6b67db131fdd230717aaf4505 (diff)
downloadaports-47c71fbe7583fa29f604f5010bc6218d3f5856e3.tar.bz2
aports-47c71fbe7583fa29f604f5010bc6218d3f5856e3.tar.xz
main/gcc: fix crossbuild and musl support
Diffstat (limited to 'main/gcc/gcc-4.8-build-args.patch')
-rw-r--r--main/gcc/gcc-4.8-build-args.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/gcc/gcc-4.8-build-args.patch b/main/gcc/gcc-4.8-build-args.patch
new file mode 100644
index 0000000000..c27e009619
--- /dev/null
+++ b/main/gcc/gcc-4.8-build-args.patch
@@ -0,0 +1,41 @@
+When cross compiling a target gcc, target flags may be used on the host
+
+Configure identifies a number of warning flags (WARN_CFLAGS and
+WARN_CXXFLAGS) from the $CC value. The cross compiler may be different
+from the host compiler and may not support the same set of flags. This
+leads to problems such as:
+
+cc1plus: error: unrecognized command line option "-Wno-narrowing"
+cc1plus: error: unrecognized command line option "-Wno-overlength-strings"
+
+Work around this problem by removing the warning flags from the
+BUILD_CXXFLAGS value, in a way similar to the BUILD_CFLAGS.
+
+Upstream-Status: Pending
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: gcc-4.8.0/gcc/configure
+===================================================================
+--- gcc-4.8.0.orig/gcc/configure
++++ gcc-4.8.0/gcc/configure
+@@ -11720,6 +10581,7 @@ STMP_FIXINC=stmp-fixinc
+ if test x$build != x$host || test "x$coverage_flags" != x
+ then
+ BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
++ BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
+ BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
+ fi
+
+Index: gcc-4.8.0/gcc/configure.ac
+===================================================================
+--- gcc-4.8.0.orig/gcc/configure.ac
++++ gcc-4.8.0/gcc/configure.ac
+@@ -1901,6 +1901,7 @@ STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_F
+ if test x$build != x$host || test "x$coverage_flags" != x
+ then
+ BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
++ BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
+ BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
+ fi
+