aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/libada-cross-shared.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-06 12:53:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 13:45:01 +0000
commit0415ebf6f9e5bae8338a45cc147f1b8536ef45d7 (patch)
treef6c392e458c69ee39d342033ad1e3043f42d3279 /main/gcc/libada-cross-shared.patch
parente6b4a901e9b25cd664d56c16fcc1e410a2e4a53d (diff)
downloadaports-0415ebf6f9e5bae8338a45cc147f1b8536ef45d7.tar.bz2
aports-0415ebf6f9e5bae8338a45cc147f1b8536ef45d7.tar.xz
main/gcc: more cross-build fixes
- remove !tracedeps; errors will be shown during packaging but they are safe to ignore. tracedeps is needed for proper so provides to be generated - fix shared libada building when cross-compiling native compiler
Diffstat (limited to 'main/gcc/libada-cross-shared.patch')
-rw-r--r--main/gcc/libada-cross-shared.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/gcc/libada-cross-shared.patch b/main/gcc/libada-cross-shared.patch
new file mode 100644
index 0000000000..0678f9cafe
--- /dev/null
+++ b/main/gcc/libada-cross-shared.patch
@@ -0,0 +1,22 @@
+--- gcc-4.8.2/libada/configure.ac.orig 2013-01-14 22:15:04.000000000 +0400
++++ gcc-4.8.2/libada/configure.ac 2014-01-21 06:53:04.254453731 +0400
+@@ -127,7 +127,7 @@
+ AC_PROG_LN_S
+
+ # Determine what to build for 'gnatlib'
+-if test $build = $target \
++if test $host = $target \
+ && test ${enable_shared} = yes ; then
+ # Note that build=target is almost certainly the wrong test; FIXME
+ default_gnatlib_target="gnatlib-shared"
+--- gcc-4.8.2/libada/configure.orig 2013-10-16 11:27:58.000000000 +0400
++++ gcc-4.8.2/libada/configure 2014-01-21 06:53:26.727581207 +0400
+@@ -2951,7 +2951,7 @@
+
+
+ # Determine what to build for 'gnatlib'
+-if test $build = $target \
++if test $host = $target \
+ && test ${enable_shared} = yes ; then
+ # Note that build=target is almost certainly the wrong test; FIXME
+ default_gnatlib_target="gnatlib-shared"