aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-02-27 14:31:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-29 08:23:29 +0000
commit3587c46af038e4bf558f3535da36eb73025eebe3 (patch)
treeb34aa826c9275899d7751a3ec623815aa912ee73 /main/gdb
parent0bb33b3cdba10b2d5f9fd051f0893ce2075d9e6f (diff)
downloadaports-3587c46af038e4bf558f3535da36eb73025eebe3.tar.bz2
aports-3587c46af038e4bf558f3535da36eb73025eebe3.tar.xz
main/gdb: upgrade to 7.11
Diffstat (limited to 'main/gdb')
-rw-r--r--main/gdb/05_all_readline-headers.patch42
-rw-r--r--main/gdb/APKBUILD22
-rw-r--r--main/gdb/gdb-linux_nat.patch26
3 files changed, 5 insertions, 85 deletions
diff --git a/main/gdb/05_all_readline-headers.patch b/main/gdb/05_all_readline-headers.patch
deleted file mode 100644
index e65adf6e6d..0000000000
--- a/main/gdb/05_all_readline-headers.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/readline/complete.c
-+++ b/readline/complete.c
-@@ -25,6 +25,11 @@
- # include <config.h>
- #endif
-
-+#ifdef HAVE_WCHAR_H /* wcwidth() */
-+# define _GNU_SOURCE
-+# include <wchar.h>
-+#endif
-+
- #include <sys/types.h>
- #include <fcntl.h>
- #if defined (HAVE_SYS_FILE_H)
---- a/readline/display.c
-+++ b/readline/display.c
-@@ -25,6 +25,11 @@
- # include <config.h>
- #endif
-
-+#ifdef HAVE_WCHAR_H /* wcwidth() */
-+# define _GNU_SOURCE
-+# include <wchar.h>
-+#endif
-+
- #include <sys/types.h>
-
- #if defined (HAVE_UNISTD_H)
---- a/readline/mbutil.c
-+++ b/readline/mbutil.c
-@@ -25,6 +25,11 @@
- # include <config.h>
- #endif
-
-+#ifdef HAVE_WCHAR_H /* wcwidth() */
-+# define _GNU_SOURCE
-+# include <wchar.h>
-+#endif
-+
- #include <sys/types.h>
- #include <fcntl.h>
- #include "posixjmp.h"
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index 93a7df5a20..2d90fe20aa 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
-pkgver=7.10.1
-pkgrel=2
+pkgver=7.11
+pkgrel=0
pkgdesc="The GNU Debugger"
url="http://sources.redhat.com/gdb/"
arch="all"
@@ -11,16 +11,7 @@ makedepends="ncurses-dev expat-dev texinfo readline-dev python-dev
autoconf automake libtool linux-headers"
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- gdb-linux_nat.patch
"
-# 05_all_readline-headers.patch
-# cpuid-pic.patch
-# gdb-linux_nat.patch
-# gdb-linux_osdata.patch
-# gdb-linux_threaddb.patch
-# gdb-amd64-debugreg.patch
-# patches were found here:
-# http://distfiles.gentoo.org/distfiles/gdb-7.4-patches-1.tar.xz
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
@@ -71,9 +62,6 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-md5sums="39e654460c9cdd80200a29ac020cfe11 gdb-7.10.1.tar.xz
-4e9d84600ca314ab4db8baf8f8ffe297 gdb-linux_nat.patch"
-sha256sums="25c72f3d41c7c8554d61cacbeacd5f40993276d2ccdec43279ac546e3993d6d5 gdb-7.10.1.tar.xz
-dcef02741f402ad34c658a90b85667e93e1d3293fe2941acd5b6821b349a1532 gdb-linux_nat.patch"
-sha512sums="17a5138277a31685a5c2a841cb47ed9bc4626ea617b8ca77750513b300299f4fbbffe504958b5372de610dcb952c679cf8fa9c1bdadd380294fbf59b6e366010 gdb-7.10.1.tar.xz
-1d5ecce8c1b597f12298d17bae308e332cb0dbae56b08c3da7829ab6a473f1b20e8e6572bab45bce5942771753604b7a9541c809f2a86d4beb38ff98b0be4bfe gdb-linux_nat.patch"
+md5sums="b5c784685e1cde65ba135feea86b6d75 gdb-7.11.tar.xz"
+sha256sums="7a434116cb630d77bb40776e8f5d3937bed11dea56bafebb4d2bc5dd389fe5c1 gdb-7.11.tar.xz"
+sha512sums="eadd2a59a1e48b1484eb2bea85256d6b1912926bc8b690793d02babf2639608bd22a0f2de77d4f60092da3b1dafeaa6d75a7cff3e84bd4e22fc46364b68e5e9f gdb-7.11.tar.xz"
diff --git a/main/gdb/gdb-linux_nat.patch b/main/gdb/gdb-linux_nat.patch
deleted file mode 100644
index 6a7276cc41..0000000000
--- a/main/gdb/gdb-linux_nat.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./gdb/linux-nat.c.orig
-+++ ./gdb/linux-nat.c
-@@ -169,6 +169,10 @@
- #define O_LARGEFILE 0
- #endif
-
-+#ifndef W_STOPCODE
-+#define W_STOPCODE(sig) ((sig) << 8 | 0x7f)
-+#endif
-+
- /* The single-threaded native GNU/Linux target_ops. We save a pointer for
- the use of the multi-threaded target. */
- static struct target_ops *linux_ops;
-@@ -4875,10 +4879,10 @@
- fortunately they don't change! */
-
- if (restart == 0)
-- restart = __SIGRTMIN;
-+ restart = SIGRTMIN;
-
- if (cancel == 0)
-- cancel = __SIGRTMIN + 1;
-+ cancel = SIGRTMIN + 1;
-
- sigaddset (set, restart);
- sigaddset (set, cancel);