aboutsummaryrefslogtreecommitdiffstats
path: root/main/gettext/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-05 18:46:16 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 08:13:38 +0000
commitd95409f62bc4fb680095b9bbbc164b609d4b3ccd (patch)
tree5897774fe1f7d210ba4bfcd0f24cc3f2b1a037bf /main/gettext/APKBUILD
parent5a2c13d37ad3b12a8b115cd2c88b3dab5b5ada2a (diff)
downloadaports-d95409f62bc4fb680095b9bbbc164b609d4b3ccd.tar.bz2
aports-d95409f62bc4fb680095b9bbbc164b609d4b3ccd.tar.xz
main/gettext: add tests, fix license
Diffstat (limited to 'main/gettext/APKBUILD')
-rw-r--r--main/gettext/APKBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index b03c204938..7d74c068d1 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -2,23 +2,24 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gettext
pkgver=0.19.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="GNU locale utilities"
url="https://www.gnu.org/software/gettext/gettext.html"
arch="all"
-license="GPL"
+license="GPL-3.0+ AND LGPL-2.1+ AND MIT"
depends=
# do _not_ add the optional dependencies on libcroco or glib
# they depend on gettext and would introduce cyclic dependencies
makedepends="perl ncurses-dev libxml2-dev libunistring-dev"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- fix-abi.patch"
+ fix-abi.patch
+ localename-fix.patch
+ skip-tests-musl.patch
+ "
subpackages="$pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang libintl $pkgname-asprintf $pkgname-libs"
-_builddir="$srcdir"/$pkgname-$pkgver
-
build() {
- cd "$_builddir"
+ cd "$builddir"
# force using system posix complaint printf
# the test is broken and fails with ash
gt_cv_func_printf_posix=yes \
@@ -28,14 +29,18 @@ build() {
--prefix=/usr \
--enable-threads=posix \
--disable-java \
- --enable-static \
- || return 1
- make || return 1
+ --enable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/charset.alias
}
@@ -47,6 +52,7 @@ static() {
libintl() {
pkgdesc="GNU gettext runtime library"
+ license="LGPL-2.1+"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libintl.so.* "$subpkgdir"/usr/lib
chmod +x "$subpkgdir"/usr/lib/libintl.so.*
@@ -54,13 +60,12 @@ libintl() {
asprintf() {
pkgdesc="GNU gettext asprintf library"
+ license="LGPL-2.1+"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libasprintf.so.* "$subpkgdir"/usr/lib
}
-md5sums="df3f5690eaa30fd228537b00cb7b7590 gettext-0.19.8.1.tar.xz
-054ee44e6dfb056efd42dc3063e273ae fix-abi.patch"
-sha256sums="105556dbc5c3fbbc2aa0edb46d22d055748b6f5c7cd7a8d99f8e7eb84e938be4 gettext-0.19.8.1.tar.xz
-48dff403e8966137e900186b2fbf9adaf7c3743ccc4c4d05b2b250009a0a6273 fix-abi.patch"
sha512sums="3553227b62f2a7d9b67c881ef889c030a6a21d5ecd210c4bf3d649df0b37193a99a68cf8fd5f2c69b6a87e847035dd9576f9bcb9363422866e26b04f4f6dd431 gettext-0.19.8.1.tar.xz
-f517a351864bb194117e7147015db9a9b0ffbb1feb22ecf39bc1c99ad904420467e267a893c3b1a76c1adb810d1b37b1c2c1273cda861ff1d260102701bc644a fix-abi.patch"
+f517a351864bb194117e7147015db9a9b0ffbb1feb22ecf39bc1c99ad904420467e267a893c3b1a76c1adb810d1b37b1c2c1273cda861ff1d260102701bc644a fix-abi.patch
+2765f8d9d72d85ad0adb87ee0edd83d3aec59995ef21a3c8bbd1ac20a3680058a2122bd3f6c37be3f50cb5ea00c19b3ad569a47ceedc8ae2cb4a6e8d4e30976d localename-fix.patch
+8fced6ec5c1f54686545aa91759f8501a0ccfa4bb66a781d282e65f7309c70ab74bf753f4969374facb135b7b9341e26d8a3e27679ea09cb1543b82dfb8a16dd skip-tests-musl.patch"