aboutsummaryrefslogtreecommitdiffstats
path: root/main/gettext
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-03-26 10:09:52 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-26 10:09:52 +0000
commit279436c41016beb7c2a4086f601dc67a3d9b886c (patch)
treecc0c143d360c8b62d49380bff2cabe63fbd020ee /main/gettext
parenta79ddf4ab189a84241a12ba39931b32ab92ae553 (diff)
downloadaports-279436c41016beb7c2a4086f601dc67a3d9b886c.tar.bz2
aports-279436c41016beb7c2a4086f601dc67a3d9b886c.tar.xz
main/gettext: fix build
- remove some optional dependencies (glib, libcroco) that would introduce cyclic dependencies - remove unneeded patch that break things - add patch to maintain abi now that build is done right fix-abi can be removed when all reverse dependencies have been rebuilt and have no libintl_*printf* symbols in them
Diffstat (limited to 'main/gettext')
-rw-r--r--main/gettext/APKBUILD24
-rw-r--r--main/gettext/dont-override-gnulib.patch12
-rw-r--r--main/gettext/fix-abi.patch11
3 files changed, 19 insertions, 28 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index d4554f9a7e..728501b3b6 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -2,28 +2,20 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gettext
pkgver=0.19.7
-pkgrel=1
+pkgrel=2
pkgdesc="GNU locale utilities"
url="http://www.gnu.org/software/gettext/gettext.html"
arch="all"
license="GPL"
depends=
-makedepends="perl ncurses-dev libxml2-dev glib-dev libcroco-dev libunistring-dev"
+# do _not_ add the optional dependencies on libcroco or glib
+# they depend on gettext and would introduce cyclic dependencies
+makedepends="perl ncurses-dev libxml2-dev libunistring-dev"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- dont-override-gnulib.patch
- "
+ fix-abi.patch"
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang libintl $pkgname-asprintf $pkgname-libs"
_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
build() {
cd "$_builddir"
@@ -58,8 +50,8 @@ asprintf() {
}
md5sums="f81e50556da41b44c1d59ac93474dca5 gettext-0.19.7.tar.xz
-f8af0b8a26dae0f054200adfef1f146a dont-override-gnulib.patch"
+054ee44e6dfb056efd42dc3063e273ae fix-abi.patch"
sha256sums="378fa86a091cec3acdece3c961bb8d8c0689906287809a8daa79dc0c6398d934 gettext-0.19.7.tar.xz
-17e5edb5128609476b1102a1ef2a9a6445d89c3f475d02ea23949f065bc0fb50 dont-override-gnulib.patch"
+48dff403e8966137e900186b2fbf9adaf7c3743ccc4c4d05b2b250009a0a6273 fix-abi.patch"
sha512sums="a8ed47fc38d8730ccd46bfa6620c0b42efcfcbfa39fa94ddecb2fa3b62b377827f29e702dc327fbc682b98534e1f54783d21a3bb5ba629f6358be00bfb4da009 gettext-0.19.7.tar.xz
-9e15b4d0ec0f39031072d8c06a20922c3c02845dbccb3455fba59f9423d970ea19baabb36d21823048a08249f148aa1e5c5e038001bffb8aa2a40051f2138f1e dont-override-gnulib.patch"
+f517a351864bb194117e7147015db9a9b0ffbb1feb22ecf39bc1c99ad904420467e267a893c3b1a76c1adb810d1b37b1c2c1273cda861ff1d260102701bc644a fix-abi.patch"
diff --git a/main/gettext/dont-override-gnulib.patch b/main/gettext/dont-override-gnulib.patch
deleted file mode 100644
index 6f4c4a58a3..0000000000
--- a/main/gettext/dont-override-gnulib.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/gettext-runtime/intl/libgnuintl.in.h
-+++ b/gettext-runtime/intl/libgnuintl.in.h
-@@ -317,6 +317,9 @@
- #include <stdio.h>
- #include <stddef.h>
-
-+#ifndef _GL_STDIO_H
-+#define _GL_STDIO_H
-+#endif
- /* Get va_list. */
- #if (defined __STDC__ && __STDC__) || defined __cplusplus || defined _MSC_VER
- # include <stdarg.h>
diff --git a/main/gettext/fix-abi.patch b/main/gettext/fix-abi.patch
new file mode 100644
index 0000000000..76a9beae0a
--- /dev/null
+++ b/main/gettext/fix-abi.patch
@@ -0,0 +1,11 @@
+--- gettext-0.19.7.orig/gettext-runtime/intl/printf.c
++++ gettext-0.19.7/gettext-runtime/intl/printf.c
+@@ -44,7 +44,7 @@
+
+ #include <stdio.h>
+
+-#if !HAVE_POSIX_PRINTF
++#if 1 || !HAVE_POSIX_PRINTF
+
+ #include <errno.h>
+ #include <limits.h>