aboutsummaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/git
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
downloadaports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.bz2
aports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.xz
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/git')
-rw-r--r--main/git/APKBUILD42
-rw-r--r--main/git/bb-tar.patch8
2 files changed, 50 insertions, 0 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
new file mode 100644
index 0000000000..2f5d36dba8
--- /dev/null
+++ b/main/git/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=git
+pkgver=1.6.3.3
+pkgrel=0
+pkgdesc="GIT - the stupid content tracker"
+url="http://git.or.cz/"
+license="GPL2"
+depends=
+subpackages="$pkgname-doc $pkgname-perl"
+makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev"
+source="http://kernel.org/pub/software/scm/git/git-$pkgver.tar.bz2
+ bb-tar.patch
+ "
+
+build () {
+ local makeopts="NO_ICONV=YesPlease
+ NO_NSEC=YesPlease
+ NO_TCLTK=YesPlease
+ NO_SVN_TESTS=YesPlease"
+
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../bb-tar.patch || return 1
+
+ make prefix=/usr DESTDIR="$pkgdir" $makeopts || return 1
+ make prefix=/usr DESTDIR="$pkgdir" $makeopts install
+}
+
+perl() {
+ depends="perl git"
+ pkgdesc="Perl scripts for git"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/perl* "$subpkgdir"/usr/lib/
+ cd "$pkgdir"
+ find -type f | xargs file --mime-type | grep perl | cut -d: -f1| while read f; do
+ mkdir -p "$subpkgdir"/${f%/*}
+ mv "$f" "$subpkgdir"/${f%/*}
+ done
+}
+
+
+md5sums="91ae46ac01dadab1962beb064abd5b60 git-1.6.3.3.tar.bz2
+04e1bdf76a0bac568f8488daad07dce7 bb-tar.patch"
diff --git a/main/git/bb-tar.patch b/main/git/bb-tar.patch
new file mode 100644
index 0000000000..0f15de5d25
--- /dev/null
+++ b/main/git/bb-tar.patch
@@ -0,0 +1,8 @@
+--- git-1.6.0.4/templates/Makefile.orig Mon Nov 10 17:10:51 2008
++++ git-1.6.0.4/templates/Makefile Mon Nov 10 17:11:25 2008
+@@ -50,4 +50,4 @@
+ install: all
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(template_instdir_SQ)'
+ (cd blt && $(TAR) cf - .) | \
+- (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xfo -)
++ (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) x)