aboutsummaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorMuh Muhten <muh.muhten@gmail.com>2015-09-30 14:14:39 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-30 22:12:58 +0200
commit141968c765ce21ea6bbf0e9d5df7b70b2931c85b (patch)
tree54988a902b1f50e8f850a2fa5f821937346cbd1b /main/git
parent7b7578a7ff4c4427d3bb00d6ef1807e14971b00d (diff)
downloadaports-141968c765ce21ea6bbf0e9d5df7b70b2931c85b.tar.bz2
aports-141968c765ce21ea6bbf0e9d5df7b70b2931c85b.tar.xz
main/git: unbreak send-email syntax errors
something seems to have gone wrong in the process of copy-pasting in a18cf0d. I haven't tested this version to make sure it works, either, but at least it syntax-checks and by inspection it seems like it ought to work. 11:30 < nmeum> a18cf0d3343c487f4a6a262f0038f21d95c35b66 just broke git-send-email http://sprunge.us/TQMW could somebody with access to main/ please revert it?
Diffstat (limited to 'main/git')
-rw-r--r--main/git/0001-senddata-16K-workaround.patch7
-rw-r--r--main/git/APKBUILD12
-rw-r--r--main/git/bb-tar.patch2
3 files changed, 10 insertions, 11 deletions
diff --git a/main/git/0001-senddata-16K-workaround.patch b/main/git/0001-senddata-16K-workaround.patch
index 2455b259c7..341a2a2e82 100644
--- a/main/git/0001-senddata-16K-workaround.patch
+++ b/main/git/0001-senddata-16K-workaround.patch
@@ -2,7 +2,7 @@ diff --git a/git-send-email.perl b/git-send-email.perl
index ae9f869..b11dce8 100755
--- a/git-send-email.perl
+++ b/git-send-email.perl
-@@ -1347,7 +1347,15 @@ Message-Id: $message_id
+@@ -1365,7 +1365,14 @@ Message-Id: $message_id
$smtp->mail( $raw_from ) or die $smtp->message;
$smtp->to( @recipients ) or die $smtp->message;
$smtp->data or die $smtp->message;
@@ -10,12 +10,11 @@ index ae9f869..b11dce8 100755
+ # Apparently datasend cannot send more than about 16 and large patches
+ # cannot be sent. Source:
+ # http://git.661346.n2.nabble.com/git-send-email-Connection-Closed-td7635648.html
-+ $smtp->datasend("$header\n") or die $smtp->message
++ $smtp->datasend("$header\n") or die $smtp->message;
+ my @lines = split /^/, $message;
+ foreach my $line (@lines) {
-+ $smtp->datasend("$line") or die $smtp->message
++ $smtp->datasend("$line") or die $smtp->message;
+ }
-+ $message") or die $smtp->message;
$smtp->dataend() or die $smtp->message;
$smtp->code =~ /250|200/ or die "Failed to send $subject\n".$smtp->message;
}
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 10d3f8deca..1f801faa24 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -237,17 +237,17 @@ _git_perl() {
md5sums="6b7d43d615fb3f0dfecf4d131e23f438 git-2.6.0.tar.xz
-e63a201556c4f089de790805c09a2e5b bb-tar.patch
-820595e9651c98b696d2636a0a471824 0001-senddata-16K-workaround.patch
+0549894076c2081d886fa5ee44c20e23 bb-tar.patch
+4f7bd16e389e7df50433cea04d967353 0001-senddata-16K-workaround.patch
75b9d8f33fbec38a8e0e06baf5165b19 git-daemon.initd
2258e95d389ccc6de0b5111d53d9eed6 git-daemon.confd"
sha256sums="211beb96ff41a83727e39704431ac388ecb1cebb5219cda067999bce4e1e15a6 git-2.6.0.tar.xz
-cb6319f47d81605e199771350154cbed0a6e85ef9042a689f2b405c64039f49c bb-tar.patch
-45632b49b0995984feb396c25e7baf8521341840ff78b9961bc62915a71e14e3 0001-senddata-16K-workaround.patch
+968e996a306dab643970c5ce1ac40926146b01b9c38a8fe81c74340a0302dbc7 bb-tar.patch
+b1440ce71aa4c2d5396472514d4f4e4adf2f6cf6c72bb7811c083f3b4e3fa700 0001-senddata-16K-workaround.patch
7918837f77b4cebce70b600b2f6da00e4c0df6b946f4ff5671c797c37b2ffc4f git-daemon.initd
aaa80bd059db549dadf4c4e27a9aa41a4b5def844f8e563c493bc8513dcd981e git-daemon.confd"
sha512sums="efcde5fa3ac56d577e25259e74f19026438ccf8888b79429eec2f141bb2a63bb83e73f65b1ea96bcc1f9f894fb90ec1b5ea81b9f0c1806d25352f6b266e7202a git-2.6.0.tar.xz
-6fa088a753c2a697e8dbef2032ed63e8c2a0553a41cff2fcff893c2f35c51d2c697054cc921c23ee606f77b93d0f340df85220b15e1c470bd352f7fba3986cd0 bb-tar.patch
-7af0b0efbdf242c672864bf3ebc7413cf789c81ab82410485168ac262d6aefb417b7fbf471aaafac52d03d0f473933339a39d64a9cd114800ce5f2d1415261a4 0001-senddata-16K-workaround.patch
+85767b5e03137008d6a96199e769e3979f75d83603ac8cb13a3481a915005637409a4fd94e0720da2ec6cd1124f35eba7cf20109a94816c4b4898a81fbc46bd2 bb-tar.patch
+3e481be3ece1a982b364955b0080dd648579d78bfcaca01f1120e0fc06cc41f162d9af50adf6eeb7cc20cf8bead6e18b2a313c444a2df3c71337ea827860cfc0 0001-senddata-16K-workaround.patch
1e707250d133d56100f0311e7c2610920d6d81809c425ebf3e6acb4a289b958707a90dc38e1c17720da6dc2758dd84bf957fe6aed3854eacea79226eb616e885 git-daemon.initd
9640f8078d68ed2678e5249da3f946fc21f50e858b94127a4221de73c6132101afcd46bc1fe33861e9a7f731c0dc9591915b8ebf376b8e690cd7135703966509 git-daemon.confd"
diff --git a/main/git/bb-tar.patch b/main/git/bb-tar.patch
index 6acfa99170..d9433ef122 100644
--- a/main/git/bb-tar.patch
+++ b/main/git/bb-tar.patch
@@ -1,6 +1,6 @@
--- a/templates/Makefile Mon Oct 26 02:57:33 2009
+++ b/templates/Makefile Mon Nov 9 14:56:27 2009
-@@ -50,4 +50,4 @@
+@@ -63,4 +63,4 @@
install: all
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(template_instdir_SQ)'
(cd blt && $(TAR) cf - .) | \