aboutsummaryrefslogtreecommitdiffstats
path: root/main/glade
diff options
context:
space:
mode:
authorAmatCoder <amatcoder@gmail.com>2015-01-15 11:37:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-01-15 15:26:32 +0000
commitb50960605b5fcd6ebf7344681beca64533a20dbb (patch)
treed9cca8cd224da5297a3397e222a33ea16a8a3a7f /main/glade
parent8d8512d008e32d6622cf554d7f00f89ae09b344f (diff)
downloadaports-b50960605b5fcd6ebf7344681beca64533a20dbb.tar.bz2
aports-b50960605b5fcd6ebf7344681beca64533a20dbb.tar.xz
main/glade: disable RANDMMAP
This allows to add items under Hierarchy tabs.
Diffstat (limited to 'main/glade')
-rw-r--r--main/glade/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/glade/APKBUILD b/main/glade/APKBUILD
index 3f6a35e8ee..d32929a7d7 100644
--- a/main/glade/APKBUILD
+++ b/main/glade/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glade
pkgver=3.18.3
-pkgrel=0
+pkgrel=1
pkgdesc="User Interface Designer for GTK+ and GNOME"
url="http://glade.gnome.org/"
arch="all"
license="GPL"
depends=
-makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc"
+makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc paxctl"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://ftp.gnome.org/pub/GNOME/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz
@@ -42,6 +42,7 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+ paxctl -c -r "$pkgdir"/usr/bin/glade
find "$pkgdir" -name '*.la' -delete
}