aboutsummaryrefslogtreecommitdiffstats
path: root/main/glade
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-01 22:48:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 07:16:04 +0000
commit6745bc52da5b12fbc135b99141ef65c8299a7191 (patch)
treef68f95cdb00abf701a3a9d76f0aa2498706a47a1 /main/glade
parent73f28ae83d0390365f3d8ffe9d0e81d1d7f4f8a5 (diff)
downloadaports-6745bc52da5b12fbc135b99141ef65c8299a7191.tar.bz2
aports-6745bc52da5b12fbc135b99141ef65c8299a7191.tar.xz
main/glade: upgrade to 3.22.0 and modernize
Diffstat (limited to 'main/glade')
-rw-r--r--main/glade/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/main/glade/APKBUILD b/main/glade/APKBUILD
index 40d0b52e6b..c5db536970 100644
--- a/main/glade/APKBUILD
+++ b/main/glade/APKBUILD
@@ -1,31 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glade
-pkgver=3.21.0
+pkgver=3.22.0
pkgrel=0
pkgdesc="User Interface Designer for GTK+ and GNOME"
url="https://glade.gnome.org/"
arch="all"
license="GPL"
-depends=
makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc paxmark"
-install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz
- "
+source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,15 +22,14 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--enable-compile-warnings=no \
- --enable-gtk-doc \
- || return 1
- make || return 1
+ --enable-gtk-doc
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" DATADIRNAME=share install || return 1
- paxmark -r "$pkgdir"/usr/bin/glade || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" DATADIRNAME=share install
+ paxmark -r "$pkgdir"/usr/bin/glade
}
-sha512sums="731fbe016f9b0d9b2d2cbee4933512958d6808f3cf24983937ce92b576396506890b1850d2c8c91602afb324362f575cd738d697546721a952fd59c1aac1a0e1 glade-3.21.0.tar.xz"
+sha512sums="6f85ec817a4236e4f69848e79510658119cdf54e017ff13fb12af63bee8a6ce1fc0376673b44a57b5ae2a74cb8b42fe0edcde69b4e9bb937caffe4b23d88edbe glade-3.22.0.tar.xz"