aboutsummaryrefslogtreecommitdiffstats
path: root/main/glfw
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 09:58:00 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-27 14:22:04 +0000
commita8005f563c13d499853e219f27349fac0abb1733 (patch)
tree76bfce3a78e78d91c080629b60aafe350b163b51 /main/glfw
parent93d75d8dbbaeba16e902758df1d0d60d5389ef10 (diff)
downloadaports-a8005f563c13d499853e219f27349fac0abb1733.tar.bz2
aports-a8005f563c13d499853e219f27349fac0abb1733.tar.xz
main/glfw: fix url
Diffstat (limited to 'main/glfw')
-rw-r--r--main/glfw/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/main/glfw/APKBUILD b/main/glfw/APKBUILD
index 0fded922e5..54283b1e3c 100644
--- a/main/glfw/APKBUILD
+++ b/main/glfw/APKBUILD
@@ -1,32 +1,29 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=glfw
pkgver=3.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Multi-platform library for OpenGL and Vulkan application development"
-url="http://www.glfw.org/"
+url="https://www.glfw.org/"
arch="all"
license="zlib"
-depends=""
depends_dev="libxinerama-dev linux-headers mesa-dev"
makedepends="$depends_dev cmake libx11-dev libxcursor-dev libxrandr-dev"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/glfw/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=ON \
- || return 1
- make || return 1
+ -DBUILD_SHARED_LIBS=ON
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
+ make DESTDIR="$pkgdir/" install
}
md5sums="91b8250b6edcc26c9f5205555070a504 glfw-3.2.1.tar.gz"