aboutsummaryrefslogtreecommitdiffstats
path: root/main/glib
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2019-02-10 19:35:04 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 09:40:25 +0000
commit0a4f50156a2cf3686810848a8a6b7587c352eede (patch)
treef461e4f5df796c50e7df468bd1aeb462edc42c91 /main/glib
parent7d5ad1ac1ca2cdbe85556c71e06f140a5423e29d (diff)
downloadaports-0a4f50156a2cf3686810848a8a6b7587c352eede.tar.bz2
aports-0a4f50156a2cf3686810848a8a6b7587c352eede.tar.xz
main/glib: prevent path deprecation warnings
Who would want all of this garbage occasionally filling their screen: Warning: Schema “org.gnome.crypto.cache” has path “/desktop/gnome/crypto/cache/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.crypto.pgp” has path “/desktop/gnome/crypto/pgp/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.seahorse” has path “/apps/seahorse/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.seahorse.manager” has path “/apps/seahorse/listing/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.locale” has path “/system/locale/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy” has path “/system/proxy/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.http” has path “/system/proxy/http/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.https” has path “/system/proxy/https/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.ftp” has path “/system/proxy/ftp/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.socks” has path “/system/proxy/socks/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Removed invalid option "--disable-gtk-doc".
Diffstat (limited to 'main/glib')
-rw-r--r--main/glib/APKBUILD7
-rw-r--r--main/glib/deprecated-no-warn.patch23
2 files changed, 27 insertions, 3 deletions
diff --git a/main/glib/APKBUILD b/main/glib/APKBUILD
index 78721be6f4..e9b7ed5916 100644
--- a/main/glib/APKBUILD
+++ b/main/glib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glib
pkgver=2.58.1
-pkgrel=2
+pkgrel=3
pkgdesc="Common C routines used by Gtk+ and other libs"
url="https://developer.gnome.org/glib/"
arch="all"
@@ -14,6 +14,7 @@ depends_dev="python3 gettext-dev zlib-dev bzip2-dev libffi-dev
makedepends="$depends_dev pcre-dev autoconf automake libtool"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
0001-gquark-fix-initialization-with-c-constructors.patch
+ deprecated-no-warn.patch
"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang $pkgname-bash-completion:bashcomp:noarch"
builddir="$srcdir"/$pkgname-$pkgver
@@ -31,7 +32,6 @@ build() {
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
- --disable-gtk-doc \
--disable-compile-warnings \
--disable-selinux \
--with-pcre=system \
@@ -79,4 +79,5 @@ bashcomp() {
}
sha512sums="115b74fcd43241e3c4b4babfb8170453b2a002ff02d5996f3c097876199cadccc1cf67b017c10c14c0d2a1bb4228027b743f4926bda0ef7d74012ed712ccd155 glib-2.58.1.tar.xz
-32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch"
+32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch
+744239ea2afb47e15d5d0214c37d7c798edac53797ca3ac14d515aee4cc3999ef9716ba744c64c40198fb259edc922559f77c9051104a568fc8ee4fc790810b1 deprecated-no-warn.patch"
diff --git a/main/glib/deprecated-no-warn.patch b/main/glib/deprecated-no-warn.patch
new file mode 100644
index 0000000000..e247ecaa06
--- /dev/null
+++ b/main/glib/deprecated-no-warn.patch
@@ -0,0 +1,23 @@
+diff -Naur a/gio/glib-compile-schemas.c b/gio/glib-compile-schemas.c
+--- a/gio/glib-compile-schemas.c 2018-09-21 15:23:52.000000000 +0100
++++ b/gio/glib-compile-schemas.c 2019-02-10 14:37:30.034879344 +0000
+@@ -1233,19 +1233,6 @@
+ return;
+ }
+
+- if (path && (g_str_has_prefix (path, "/apps/") ||
+- g_str_has_prefix (path, "/desktop/") ||
+- g_str_has_prefix (path, "/system/")))
+- {
+- gchar *message = NULL;
+- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
+- "Paths starting with "
+- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
+- id, path);
+- g_printerr ("%s\n", message);
+- g_free (message);
+- }
+-
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+