aboutsummaryrefslogtreecommitdiffstats
path: root/main/glib
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2019-11-27 19:30:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-06 06:17:20 +0000
commit83ec09f9c76224d7e4c3c2b1baed8bc477c5ad30 (patch)
tree69460eb5e2b6db83742314e32f39e1b3763d3e15 /main/glib
parentc9a0209cbdc3aa5d1e79297f9ac168adef97b36d (diff)
downloadaports-83ec09f9c76224d7e4c3c2b1baed8bc477c5ad30.tar.bz2
aports-83ec09f9c76224d7e4c3c2b1baed8bc477c5ad30.tar.xz
main/glib: fix mips FTBFS
Diffstat (limited to 'main/glib')
-rw-r--r--main/glib/APKBUILD6
-rw-r--r--main/glib/mips-disable-memory-barrier.patch11
-rw-r--r--main/glib/mips-disable-objcopy-tests.patch11
3 files changed, 27 insertions, 1 deletions
diff --git a/main/glib/APKBUILD b/main/glib/APKBUILD
index 6e01d0fc69..69f8aa16a4 100644
--- a/main/glib/APKBUILD
+++ b/main/glib/APKBUILD
@@ -17,6 +17,8 @@ source="https://download.gnome.org/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz
0001-gquark-fix-initialization-with-c-constructors.patch
deprecated-no-warn.patch
musl-libintl.patch
+ mips-disable-memory-barrier.patch
+ mips-disable-objcopy-tests.patch
"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang"
@@ -69,4 +71,6 @@ static() {
sha512sums="359ccbb8809443b5ad0947dccafe2c06daa8e8a0dc643611d17f46bbc388305edc21aca0b550c01fe9180bb42d7291da19814dc4e5ac8df7798cafd7203560a7 glib-2.62.3.tar.xz
32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch
744239ea2afb47e15d5d0214c37d7c798edac53797ca3ac14d515aee4cc3999ef9716ba744c64c40198fb259edc922559f77c9051104a568fc8ee4fc790810b1 deprecated-no-warn.patch
-6ec43e76bb973367bd99c5e2077113e86df2b120b3788aeeb4692a572392bba7227e8217b28a918e02ad82fcb8ca6d260c3221b84688774d86779755af51a847 musl-libintl.patch"
+6ec43e76bb973367bd99c5e2077113e86df2b120b3788aeeb4692a572392bba7227e8217b28a918e02ad82fcb8ca6d260c3221b84688774d86779755af51a847 musl-libintl.patch
+f853ddb4ff8231e1df15323773af938323517b643b241fc635d05f7d6e103ff18417d203c65661c7dd0b5e44c5d74c71a497e82281c2bb4ed4e2fe9b9ed7140f mips-disable-memory-barrier.patch
+22a738e2ad7bb419e0fd07ad1c796d5307e2952aa9801fff2adb8747ecc1c5b688f492e93ebe789fc2951408e54e52ca0df5cdadf8456630de1121baaf10a7b4 mips-disable-objcopy-tests.patch"
diff --git a/main/glib/mips-disable-memory-barrier.patch b/main/glib/mips-disable-memory-barrier.patch
new file mode 100644
index 0000000000..e442764792
--- /dev/null
+++ b/main/glib/mips-disable-memory-barrier.patch
@@ -0,0 +1,11 @@
+--- glib-2.62.3.orig/meson.build
++++ glib-2.62.3/meson.build
+@@ -1586,7 +1586,7 @@
+
+ # We need a more robust approach here...
+ host_cpu_family = host_machine.cpu_family()
+-if host_cpu_family == 'x86' or host_cpu_family == 'x86_64' or host_cpu_family == 's390' or host_cpu_family == 's390x' or host_cpu_family.startswith('arm') or host_cpu_family == 'aarch64' or host_cpu_family.startswith('crisv32') or host_cpu_family.startswith('etrax')
++if host_cpu_family == 'x86' or host_cpu_family == 'x86_64' or host_cpu_family == 's390' or host_cpu_family == 's390x' or host_cpu_family.startswith('arm') or host_cpu_family == 'aarch64' or host_cpu_family.startswith('crisv32') or host_cpu_family.startswith('etrax') or host_cpu_family.startswith('mips')
+ glib_memory_barrier_needed = false
+ elif host_cpu_family.startswith('sparc') or host_cpu_family.startswith('alpha') or host_cpu_family.startswith('powerpc') or host_cpu_family == 'ia64'
+ glib_memory_barrier_needed = true
diff --git a/main/glib/mips-disable-objcopy-tests.patch b/main/glib/mips-disable-objcopy-tests.patch
new file mode 100644
index 0000000000..8947996ea5
--- /dev/null
+++ b/main/glib/mips-disable-objcopy-tests.patch
@@ -0,0 +1,11 @@
+--- glib-2.62.3.orig/gio/tests/meson.build
++++ glib-2.62.3/gio/tests/meson.build
+@@ -579,7 +579,7 @@
+ # LLVM once that support is in a stable release.
+ objcopy = find_program('objcopy', required : false)
+
+- if build_machine.system() == 'linux' and cc.get_id() == 'gcc' and objcopy.found()
++ if build_machine.system() == 'linux' and cc.get_id() == 'gcc' and objcopy.found() and not build_machine.cpu_family().startswith('mips')
+ test_gresource_binary = custom_target('test5.gresource',
+ input : 'test5.gresource.xml',
+ output : 'test5.gresource',