aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnome-control-center/link-gmodule.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:04:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:04:52 +0000
commit6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8 (patch)
tree6bd06d5097230501b18b149597c55a291f1d8ec6 /main/gnome-control-center/link-gmodule.patch
parent07abe2e0f46ff69f55ae7bcdb1aa28661e684726 (diff)
downloadaports-6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8.tar.bz2
aports-6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8.tar.xz
main/gnome-control-center: split out -lang and gmodule link fix
Diffstat (limited to 'main/gnome-control-center/link-gmodule.patch')
-rw-r--r--main/gnome-control-center/link-gmodule.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/gnome-control-center/link-gmodule.patch b/main/gnome-control-center/link-gmodule.patch
new file mode 100644
index 0000000000..9bf14ec961
--- /dev/null
+++ b/main/gnome-control-center/link-gmodule.patch
@@ -0,0 +1,26 @@
+diff --git a/capplets/appearance/Makefile.in b/capplets/appearance/Makefile.in
+index 4b8df30..9c62c4f 100644
+--- a/capplets/appearance/Makefile.in
++++ b/capplets/appearance/Makefile.in
+@@ -386,7 +386,7 @@ gnome_appearance_properties_LDADD = \
+ $(top_builddir)/capplets/common/libcommon.la \
+ $(GNOMECC_CAPPLETS_LIBS) \
+ $(FONT_CAPPLET_LIBS) \
+- $(METACITY_LIBS)
++ $(METACITY_LIBS) -lgmodule-2.0
+
+ gnome_appearance_properties_LDFLAGS = -export-dynamic
+ gtkbuilderdir = $(pkgdatadir)/ui
+diff --git a/capplets/common/Makefile.in b/capplets/common/Makefile.in
+index 00e594a..5f1849a 100644
+--- a/capplets/common/Makefile.in
++++ b/capplets/common/Makefile.in
+@@ -365,7 +365,7 @@ gnome_theme_test_SOURCES = \
+
+ gnome_theme_test_LDADD = \
+ libcommon.la \
+- $(GNOMECC_CAPPLETS_LIBS)
++ $(GNOMECC_CAPPLETS_LIBS) -lgmodule-2.0
+
+ all: all-am
+