aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnome-vfs
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-02-05 11:10:11 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-02-05 11:10:11 +0000
commit76638ad352177cada21e71eec3a56884a5541f91 (patch)
treedb83b5573e660926876c206b90c18b19044630e5 /main/gnome-vfs
parentdd781746fe2bd62e6cf0468672c8c6310c72d4bd (diff)
downloadaports-76638ad352177cada21e71eec3a56884a5541f91.tar.bz2
aports-76638ad352177cada21e71eec3a56884a5541f91.tar.xz
main/gnome-vfs: speedup gconf
Diffstat (limited to 'main/gnome-vfs')
-rw-r--r--main/gnome-vfs/APKBUILD2
-rw-r--r--main/gnome-vfs/gnome-vfs.post-install9
-rw-r--r--main/gnome-vfs/gnome-vfs.post-upgrade9
-rw-r--r--main/gnome-vfs/gnome-vfs.pre-deinstall9
4 files changed, 19 insertions, 10 deletions
diff --git a/main/gnome-vfs/APKBUILD b/main/gnome-vfs/APKBUILD
index 20aec0d0c7..6ebf7ddf32 100644
--- a/main/gnome-vfs/APKBUILD
+++ b/main/gnome-vfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-vfs
pkgver=2.24.4
-pkgrel=5
+pkgrel=6
pkgdesc="GNOME virtual filesystem subsystem"
url="http://projects.gnome.org/gnome-vfs"
arch="all"
diff --git a/main/gnome-vfs/gnome-vfs.post-install b/main/gnome-vfs/gnome-vfs.post-install
index 00ff29a655..a636ef758f 100644
--- a/main/gnome-vfs/gnome-vfs.post-install
+++ b/main/gnome-vfs/gnome-vfs.post-install
@@ -1,7 +1,10 @@
#!/bin/sh
for i in desktop_default_applications.schemas system_http_proxy.schemas desktop_gnome_url_handlers.schemas system_smb.schemas system_dns_sd.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i > /dev/null
+ SCHEMAS="$SCHEMAS /etc/gconf/schemas/$i"
done
+
+echo "Installing gnome-vfs GConf2 schemas"
+
+GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule $SCHEMAS > /dev/null
diff --git a/main/gnome-vfs/gnome-vfs.post-upgrade b/main/gnome-vfs/gnome-vfs.post-upgrade
index 00ff29a655..a636ef758f 100644
--- a/main/gnome-vfs/gnome-vfs.post-upgrade
+++ b/main/gnome-vfs/gnome-vfs.post-upgrade
@@ -1,7 +1,10 @@
#!/bin/sh
for i in desktop_default_applications.schemas system_http_proxy.schemas desktop_gnome_url_handlers.schemas system_smb.schemas system_dns_sd.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i > /dev/null
+ SCHEMAS="$SCHEMAS /etc/gconf/schemas/$i"
done
+
+echo "Installing gnome-vfs GConf2 schemas"
+
+GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule $SCHEMAS > /dev/null
diff --git a/main/gnome-vfs/gnome-vfs.pre-deinstall b/main/gnome-vfs/gnome-vfs.pre-deinstall
index 3cd527cfa3..0e5f3c7874 100644
--- a/main/gnome-vfs/gnome-vfs.pre-deinstall
+++ b/main/gnome-vfs/gnome-vfs.pre-deinstall
@@ -1,7 +1,10 @@
#!/bin/sh
for i in desktop_default_applications.schemas system_http_proxy.schemas desktop_gnome_url_handlers.schemas system_smb.schemas system_dns_sd.schemas; do
- echo "Uninstalling GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i > /dev/null
+ SCHEMAS="$SCHEMAS /etc/gconf/schemas/$i"
done
+
+echo "Uninstalling gnome-vfs GConf2 schemas"
+
+GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule $SCHEMAS > /dev/null