aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnumeric/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-01 17:18:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-01 17:18:57 +0000
commit30cda290c45e8ffb0dd6613ba874b15fc03b1d75 (patch)
treeda7719c1c0ed31f28ebd8ce18813f238323a4eda /main/gnumeric/APKBUILD
parent71a35ed373786a483254518b4799ed12bf423087 (diff)
downloadaports-30cda290c45e8ffb0dd6613ba874b15fc03b1d75.tar.bz2
aports-30cda290c45e8ffb0dd6613ba874b15fc03b1d75.tar.xz
main/gnumeric: upgrade to 1.12.33
Diffstat (limited to 'main/gnumeric/APKBUILD')
-rw-r--r--main/gnumeric/APKBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/main/gnumeric/APKBUILD b/main/gnumeric/APKBUILD
index d19cd5d151..72b580ded6 100644
--- a/main/gnumeric/APKBUILD
+++ b/main/gnumeric/APKBUILD
@@ -1,29 +1,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnumeric
-pkgver=1.12.31
+pkgver=1.12.33
pkgrel=0
pkgdesc="A GNOME Spreadsheet Program"
url="http://www.gnome.org/projects/gnumeric/"
arch="all"
license="GPL"
makedepends="gtk+3.0-dev intltool desktop-file-utils goffice-dev rarian
- python2-dev py-gobject3-dev libxslt-dev bison flex"
+ python2-dev py-gobject3-dev libxslt-dev bison flex itstool
+ libxml2-utils
+ autoconf automake libtool"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.12/$pkgname-$pkgver.tar.xz"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.12/$pkgname-$pkgver.tar.xz
+ gnumeric-1.12.33-destdir.patch
+ gnumeric-1.12.33-docbook.patch
+ "
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ autoreconf -vif
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,15 +39,20 @@ build() {
--disable-static \
--with-python \
|| return 1
- make itlocaledir="/usr/share/locale" || return 1
+ make || return 1
}
package() {
- cd "$_builddir"
- make -j1 itlocaledir="/usr/share/locale" \
- DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="d61f890da7a3e0e14adfc65b93583c67 gnumeric-1.12.31.tar.xz"
-sha256sums="c8ace78e75c280dced3f15b27c44c7a98e8d21cd8361c6b2599cce191f6d6ae7 gnumeric-1.12.31.tar.xz"
-sha512sums="e6d6cef034517015fffc2938e69f1b9e47f12ad7ae5fc6fcf7c5d95bda06d37c234048c2621fda8f2576a811b20698aea8a3313d020c1bceb8337f66f8d41fb6 gnumeric-1.12.31.tar.xz"
+md5sums="427e7a972bfe81ccf2c017b710968bef gnumeric-1.12.33.tar.xz
+c38369278060da82815781b72edec5cb gnumeric-1.12.33-destdir.patch
+3093843382aca463c84d6bb562c4fb7d gnumeric-1.12.33-docbook.patch"
+sha256sums="7eade408b6c20d2e8ad557d539e5e2f29705845a2eaa181b38934bb0cad49c0b gnumeric-1.12.33.tar.xz
+7118e5108ee906098fcdfd8390ddeb6c7a225f92ab36a1a8bd2c05d5fd902e44 gnumeric-1.12.33-destdir.patch
+fb3bf7eb30552b7ae75f7b2dca6326b015bd197dd7e8ec43f8e14ab6de2d4d85 gnumeric-1.12.33-docbook.patch"
+sha512sums="75a91cab88fdf7788e5ae3a7ab8e6fc9dd0f362bd2410841870c9e93e40ed84bd99a4f143b19af73300a6ac42f2f37c3331038e842b38bed2fa2aa38205f071b gnumeric-1.12.33.tar.xz
+7b2e37d5226172df358ef0af12fda55114f2c64cb05de189d577e84c0b03025e91860d998e29529ab9ffcf639c394a09d64d5400ab283b489dd0303b7959dfa3 gnumeric-1.12.33-destdir.patch
+d2f1f232cd8ab92d72a90e7288d2f7653df385bd132766dbf27de56f90af1bf56ef3c545af9decd617dac3571adc36eb0fa4b901ca41feabf35b20dfff919fcb gnumeric-1.12.33-docbook.patch"