aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnutls
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-13 23:20:08 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-13 23:27:13 +0200
commit37cde2005d513c433cefe6fc7fa73021c02606ab (patch)
treed51e4aa843a7289ddbf77ab84754be14d2ad33ae /main/gnutls
parentdd551abf7b2ed4e460d04075ee5ef40231eac523 (diff)
downloadaports-37cde2005d513c433cefe6fc7fa73021c02606ab.tar.bz2
aports-37cde2005d513c433cefe6fc7fa73021c02606ab.tar.xz
main/gnutls: run tests
Diffstat (limited to 'main/gnutls')
-rw-r--r--main/gnutls/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/main/gnutls/APKBUILD b/main/gnutls/APKBUILD
index 3c5cb8e79a..fea32fab75 100644
--- a/main/gnutls/APKBUILD
+++ b/main/gnutls/APKBUILD
@@ -8,6 +8,7 @@ pkgdesc="A TLS protocol implementation"
url="http://www.gnutls.org/"
arch="all"
license="GPL"
+checkdepends="coreutils diffutils"
makedepends="nettle-dev zlib-dev libtasn1-dev p11-kit-dev libunistring-dev texinfo"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-utils $pkgname-c++:xx"
_v=${pkgver%.*}
@@ -38,6 +39,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
make -j1 DESTDIR="$pkgdir" \
-C "$builddir" install