aboutsummaryrefslogtreecommitdiffstats
path: root/main/goffice0.8/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-12-28 11:25:55 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-12-28 11:25:55 +0100
commit4ea70feb9ffbea364f3d8a50c7c019a13688f4a6 (patch)
tree98eeeb7c34b9105c60911a87baa351e3a81e941b /main/goffice0.8/APKBUILD
parent6633f5f2e86a53a5bac6eff65f9288e9761eea25 (diff)
downloadaports-4ea70feb9ffbea364f3d8a50c7c019a13688f4a6.tar.bz2
aports-4ea70feb9ffbea364f3d8a50c7c019a13688f4a6.tar.xz
main/goffice0.8: new aport
Abiword still requires gtk2, therefore it needs older goffice.
Diffstat (limited to 'main/goffice0.8/APKBUILD')
-rw-r--r--main/goffice0.8/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/goffice0.8/APKBUILD b/main/goffice0.8/APKBUILD
new file mode 100644
index 0000000000..9a2ec00643
--- /dev/null
+++ b/main/goffice0.8/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=goffice0.8
+_realname=goffice
+pkgver=0.8.17
+pkgrel=0
+_maj=${pkgver%%.*}
+_min=${pkgver#${_maj}.}
+_min=${_min%%.*}
+pkgdesc="A library of document-centric objects and utilities built on top of GLib and Gtk+"
+url="http://www.gnome.org"
+arch="all"
+license="GPL"
+depends_dev="glib-dev libgsf-dev cairo-dev libxml2-dev"
+makedepends="$depends_dev intltool gtk+-dev autoconf automake libtool gtk-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://ftp.gnome.org/pub/gnome/sources/$_realname/$_maj.$_min/$_realname-$pkgver.tar.bz2
+ goffice-0.8.17-no-pcre.patch
+ use-apiver-for-dirs.patch
+ "
+
+prepare() {
+ cd "$srcdir"/$_realname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ libtoolize --force && aclocal && autoconf && automake
+}
+
+build() {
+ cd "$srcdir"/$_realname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --without-gconf \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$_realname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/goffice/*/plugins/*/*.la
+}
+
+md5sums="b4c924457163e02daf8a8d2428f51d10 goffice-0.8.17.tar.bz2
+bf54fa8b063b79b857e5b572e94a162a goffice-0.8.17-no-pcre.patch
+4054dd4ecec9f7e48d71413648f73768 use-apiver-for-dirs.patch"