aboutsummaryrefslogtreecommitdiffstats
path: root/main/goffice
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-11 13:47:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-11 14:06:12 +0000
commit89a0eadfa627882735c5da6175e27ef1268f7dbc (patch)
treed85aafbd02d6fc4a053be3c181cf2213bc025031 /main/goffice
parentbae6448b567ed4110bd750ca31c4d0f8d8a9453a (diff)
downloadaports-89a0eadfa627882735c5da6175e27ef1268f7dbc.tar.bz2
aports-89a0eadfa627882735c5da6175e27ef1268f7dbc.tar.xz
main/goffice: upgrade to 0.10.1
Diffstat (limited to 'main/goffice')
-rw-r--r--main/goffice/APKBUILD18
-rw-r--r--main/goffice/cspline.patch36
-rw-r--r--main/goffice/goffice-0.8.17-no-pcre.patch219
-rw-r--r--main/goffice/localedir.patch11
4 files changed, 60 insertions, 224 deletions
diff --git a/main/goffice/APKBUILD b/main/goffice/APKBUILD
index bd1265f169..5c29ac5da6 100644
--- a/main/goffice/APKBUILD
+++ b/main/goffice/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=goffice
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=0
_maj=${pkgver%%.*}
_min=${pkgver#${_maj}.}
@@ -12,9 +12,9 @@ license="GPL"
depends_dev="glib-dev libgsf-dev cairo-dev libxml2-dev gtk+3.0-dev librsvg-dev"
makedepends="$depends_dev intltool gtk+-dev autoconf automake libtool gtk-doc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$_maj.$_min/$pkgname-$pkgver.tar.xz"
-# goffice-0.8.17-no-pcre.patch
-# "
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$_maj.$_min/$pkgname-$pkgver.tar.xz
+ localedir.patch
+ cspline.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -43,4 +43,12 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/goffice/*/plugins/*/*.la
}
-md5sums="a260760abed11f510db712305d82884b goffice-0.10.0.tar.xz"
+md5sums="90fd17c6fe205b779571e00d9b0b4727 goffice-0.10.1.tar.xz
+0d9a3666263a57c43574b89b638a6503 localedir.patch
+819ea03fb7dda007038b0e1834e168b9 cspline.patch"
+sha256sums="5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0 goffice-0.10.1.tar.xz
+05bfe0446d29ae7dd443600a58d172d1bb4f3d1d24886e785dfcc108c2d0e8ce localedir.patch
+eac82c73e7f11eaf484d5978b91dd748532c71615acf860564d6a35196d9b686 cspline.patch"
+sha512sums="057611dd0ce940e68962595ec157d142e3d96541e6ff9f880e1e277c58183001301dcaef7b7438ee1e9830497482cde69ce0ec3f6068af2a7327e6a3b6522e2c goffice-0.10.1.tar.xz
+4e1138f1ec2e4f2d1eb85df653542195aa9caf512c759c54f6b275750a819d9684f590e0c8c01203050c1b3901f57ac6e113649f05ddc09b4d782307fd4e58d6 localedir.patch
+33d027287268c4b0997d44bd208d00c29a927eb32c87c9b9f370ce590611de49a423e733086d977e97fff6a1297e435f01c361d5b143c4b9533ed2a6b98aaf5d cspline.patch"
diff --git a/main/goffice/cspline.patch b/main/goffice/cspline.patch
new file mode 100644
index 0000000000..26382aab6a
--- /dev/null
+++ b/main/goffice/cspline.patch
@@ -0,0 +1,36 @@
+From 01f93869b7e2e9b38bd62c94d9d71103dffa4f08 Mon Sep 17 00:00:00 2001
+From: Morten Welinder <terra@gnome.org>
+Date: Sun, 10 Mar 2013 20:18:01 +0000
+Subject: Math: fix problems with cspline boxed type.
+
+---
+diff --git a/goffice/math/go-cspline.c b/goffice/math/go-cspline.c
+index a3d0991..d321847 100644
+--- a/goffice/math/go-cspline.c
++++ b/goffice/math/go-cspline.c
+@@ -229,9 +229,9 @@ SUFFIX(go_cspline_ref) (GOCSpline *sp)
+
+ GType
+ #ifdef LONG_DOUBLE
+-go_cspline_get_type (void)
+-#else
+ go_csplinel_get_type (void)
++#else
++go_cspline_get_type (void)
+ #endif
+ {
+ static GType t = 0;
+@@ -239,9 +239,9 @@ go_csplinel_get_type (void)
+ if (t == 0) {
+ t = g_boxed_type_register_static (
+ #ifdef LONG_DOUBLE
+- "GOCSpline",
+-#else
+ "GOCSplinel",
++#else
++ "GOCSpline",
+ #endif
+ (GBoxedCopyFunc)SUFFIX(go_cspline_ref),
+ (GBoxedFreeFunc)SUFFIX(go_cspline_destroy));
+--
+cgit v0.9.1
diff --git a/main/goffice/goffice-0.8.17-no-pcre.patch b/main/goffice/goffice-0.8.17-no-pcre.patch
deleted file mode 100644
index 4691acdcd8..0000000000
--- a/main/goffice/goffice-0.8.17-no-pcre.patch
+++ /dev/null
@@ -1,219 +0,0 @@
-From 00b816027e11f5fd890df07ae94d720cce106f34 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Fri, 20 Apr 2012 14:57:59 -0400
-Subject: [PATCH] Drop pcre workaround for <glib-2.15.1
-
-For unknown reason, it sometimes gets enabled even on modern systems,
-causing problems.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=670316
----
- configure.in | 24 +----------
- goffice/utils/regutf8.c | 106 -----------------------------------------------
- 2 files changed, 1 insertions(+), 129 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index fd40d53..62e299d 100644
---- a/configure.in
-+++ b/configure.in
-@@ -93,7 +93,7 @@ PKG_PROG_PKG_CONFIG
-
- dnl *****************************
- goffice_reqs="
-- glib-2.0 >= 2.8.0
-+ glib-2.0 >= 2.16.0
- gobject-2.0 >= 2.16.0
- gmodule-2.0 >= 2.16.0
- gio-2.0 >= 2.16.0
-@@ -492,13 +492,6 @@ SAVE_CFLAGS=$CFLAGS
- SAVE_LIBS=$LIBS
- CFLAGS="$CFLAGS $GOFFICE_CFLAGS"
- LIBS="$GOFFICE_LIBS $LIBS"
--AC_MSG_CHECKING([for G_REGEX_ERROR_STRAY_BACKSLASH])
--AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <glib/gregex.h>]], [[GRegexError error=G_REGEX_ERROR_STRAY_BACKSLASH;]])],
-- [AC_DEFINE(HAVE_G_REGEX_ERROR_STRAY_BACKSLASH, 1, [Define if G_REGEX_ERROR_STRAY_BACKSLASH is defined])
-- glib_has_G_REGEX_ERROR_STRAY_BACKSLASH=yes
-- AC_MSG_RESULT(yes)],
-- [AC_MSG_RESULT(no)
-- glib_has_G_REGEX_ERROR_STRAY_BACKSLASH=no])
- if test "x$goffice_with_gtk" = "xtrue" ; then
- AC_CHECK_FUNCS(gtk_dialog_get_response_for_widget)
- AC_CHECK_FUNCS(gtk_widget_set_tooltip_text gtk_tool_item_set_tooltip_text,
-@@ -511,21 +504,6 @@ if test $gtk_disable_deprecated = yes; then
- CFLAGS="$CFLAGS -DGTK_DISABLE_DEPRECATED"
- fi
-
--if test "x$glib_has_G_REGEX_ERROR_STRAY_BACKSLASH" = "xno"; then
-- dnl Check for working pcre
-- AC_CHECK_HEADER(pcre.h,[], AC_MSG_ERROR([Header files for PCRE were not found]))
-- AC_CHECK_LIB(pcre,pcre_compile2,[], AC_MSG_ERROR([The PCRE library is missing or too old]))
-- AC_MSG_CHECKING([for UTF-8 support in pcre])
-- if (pcretest -C 2>&1) | grep -i "^ *UTF-8 support" >/dev/null; then
-- AC_MSG_RESULT(yes)
-- LIBS="$LIBS -lpcre"
-- EXTRA_LIBS="$EXTRA_LIBS -lpcre"
-- else
-- AC_MSG_ERROR([The installed PCRE library is not configured for UTF-8 support.])
-- fi
--fi
--
--
- AC_DEFUN([GOFFICE_CHECK_FUNC],
- [AC_CHECK_FUNC([$1],
- [],
-diff --git a/goffice/utils/regutf8.c b/goffice/utils/regutf8.c
-index bc4aae4..3f32dd6 100644
---- a/goffice/utils/regutf8.c
-+++ b/goffice/utils/regutf8.c
-@@ -7,9 +7,6 @@
-
- #include <goffice/goffice-config.h>
- #include "regutf8.h"
--#ifndef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
--#include <pcre.h>
--#endif
- #include "go-glib-extras.h"
- #include <gsf/gsf-impl-utils.h>
- #include <glib/gi18n-lib.h>
-@@ -21,11 +18,7 @@ void
- go_regfree (GORegexp *gor)
- {
- if (gor->ppcre) {
--#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
- g_regex_unref (gor->ppcre);
--#else
-- pcre_free (gor->ppcre);
--#endif
- gor->ppcre = NULL;
- }
- }
-@@ -70,7 +63,6 @@ go_regerror (int errcode, const GORegexp *gor, char *dst, size_t dstsize)
- int
- go_regcomp (GORegexp *gor, const char *pat, int cflags)
- {
--#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
- GError *error = NULL;
- GRegex *r;
- int coptions =
-@@ -119,47 +111,6 @@ go_regcomp (GORegexp *gor, const char *pat, int cflags)
- gor->nosub = (cflags & GO_REG_NOSUB) != 0;
- return 0;
- }
--#else
-- const char *errorptr;
-- int errorofs, errorcode;
-- pcre *r;
-- int coptions =
-- PCRE_UTF8 |
-- PCRE_NO_UTF8_CHECK |
-- ((cflags & GO_REG_ICASE) ? PCRE_CASELESS : 0) |
-- ((cflags & GO_REG_NEWLINE) ? PCRE_MULTILINE : 0);
--
-- if (&pcre_compile2 == NULL) {
-- g_error ("libgoffice has been dynamically linked against a libpcre\n"
-- "that lacks the pcre_compile2 function. This indicates a\n"
-- "distribution dependency problem. Please report this at\n"
-- "bugzilla.gnome.org and for you distribution.");
-- }
--
-- gor->ppcre = r = pcre_compile2 (pat, coptions,
-- &errorcode, &errorptr, &errorofs,
-- NULL);
--
-- if (r == NULL) {
-- switch (errorcode) {
-- case 1: case 2: case 3: case 37: return GO_REG_EESCAPE;
-- case 4: case 5: return GO_REG_EBRACE;
-- case 6: return GO_REG_EBRACK;
-- case 7: case 30: return GO_REG_ECTYPE;
-- case 8: return GO_REG_ERANGE;
-- case 9: case 10: return GO_REG_BADRPT;
-- case 14: case 18: case 22: return GO_REG_EPAREN;
-- case 15: return GO_REG_ESUBREG;
-- case 19: case 20: return GO_REG_ESIZE;
-- case 21: return GO_REG_ESPACE;
-- default: return GO_REG_BADPAT;
-- }
-- } else {
-- gor->re_nsub = pcre_info (r, NULL, NULL);
-- gor->nosub = (cflags & GO_REG_NOSUB) != 0;
-- return 0;
-- }
--#endif
- return 0;
- }
-
-@@ -167,7 +118,6 @@ int
- go_regexec (const GORegexp *gor, const char *txt,
- size_t nmatch, GORegmatch *pmatch, int eflags)
- {
--#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
- int eoptions =
- ((eflags & GO_REG_NOTBOL) ? G_REGEX_MATCH_NOTBOL : 0) |
- ((eflags & GO_REG_NOTEOL) ? G_REGEX_MATCH_NOTEOL : 0);
-@@ -196,62 +146,6 @@ go_regexec (const GORegexp *gor, const char *txt,
- g_match_info_free (match_info);
-
- return matched ? GO_REG_NOERROR : GO_REG_NOMATCH;
--#else
-- size_t txtlen = strlen (txt);
-- int eoptions =
-- ((eflags & GO_REG_NOTBOL) ? PCRE_NOTBOL : 0) |
-- ((eflags & GO_REG_NOTEOL) ? PCRE_NOTEOL : 0);
-- int res;
-- int *offsets, *allocated;
-- int offsetcount;
-- if (gor->nosub)
-- nmatch = 0;
--
-- if (nmatch > 0) {
-- /* Paranoia. */
-- if (nmatch >= G_MAXINT / sizeof (int) / 3)
-- return GO_REG_ESPACE;
--
-- offsetcount = nmatch * 3;
-- offsets = allocated = g_try_new (int, offsetcount);
-- if (!offsets)
-- return GO_REG_ESPACE;
-- } else {
-- offsets = allocated = NULL;
-- offsetcount = 0;
-- }
--
-- res = pcre_exec (gor->ppcre, NULL, txt, txtlen, 0, eoptions,
-- offsets, offsetcount);
-- if (res >= 0) {
-- int i;
--
-- if (res == 0) res = nmatch;
--
-- for (i = 0; i < res; i++) {
-- pmatch[i].rm_so = offsets[i * 2];
-- pmatch[i].rm_eo = offsets[i * 2 + 1];
-- }
-- for (; i < (int)nmatch; i++) {
-- pmatch[i].rm_so = -1;
-- pmatch[i].rm_eo = -1;
-- }
-- g_free (allocated);
-- return GO_REG_NOERROR;
-- }
--
-- g_free (allocated);
-- switch (res) {
-- case PCRE_ERROR_NOMATCH:
-- return GO_REG_NOMATCH;
-- case PCRE_ERROR_BADUTF8:
-- case PCRE_ERROR_BADUTF8_OFFSET:
-- /* POSIX doesn't seem to foresee this kind of error. */
-- return GO_REG_BADPAT;
-- default:
-- return GO_REG_ESPACE;
-- }
--#endif
- }
-
- /* ------------------------------------------------------------------------- */
---
-1.7.8.5
-
diff --git a/main/goffice/localedir.patch b/main/goffice/localedir.patch
new file mode 100644
index 0000000000..99f4462f73
--- /dev/null
+++ b/main/goffice/localedir.patch
@@ -0,0 +1,11 @@
+--- ./po/Makefile.in.in.orig 2013-03-11 13:44:04.448962814 +0000
++++ ./po/Makefile.in.in 2013-03-11 13:45:46.526579564 +0000
+@@ -34,7 +34,7 @@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++itlocaledir = $(datadir)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.