aboutsummaryrefslogtreecommitdiffstats
path: root/main/gperf
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
commit9fddb4d5b41c0b5e69d5ee138297e95eff290302 (patch)
treeb353402b4af0ac5b912dc78ca7d996c397b8e2e3 /main/gperf
parentccf26410d30adc8c1934dd553687157ed6e31d69 (diff)
parent8c1128e93e03012dabadb9a3f723dbd20eb60cd4 (diff)
downloadaports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.bz2
aports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.xz
Merged from Alpine main repository.
Merge Conflicts: main/abuild/APKBUILD main/cramfs/APKBUILD main/curl/APKBUILD main/dialog/APKBUILD main/libconfig/APKBUILD main/snort/APKBUILD main/syslinux/APKBUILD
Diffstat (limited to 'main/gperf')
-rw-r--r--main/gperf/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/gperf/APKBUILD b/main/gperf/APKBUILD
index cc97c06d5c..84d5ab2c06 100644
--- a/main/gperf/APKBUILD
+++ b/main/gperf/APKBUILD
@@ -1,21 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gperf
pkgver=3.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Perfect hash function generator."
url="http://www.gnu.org/software/gperf/"
license="GPL"
subpackages="$pkgname-doc"
-depends="uclibc libgcc uclibc++"
-makedepends="uclibc++-dev"
+depends=
+makedepends=
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build ()
{
cd "$srcdir"/$pkgname-$pkgver
- export CXX=g++-uc
./configure --prefix=/usr
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
md5sums="c1f1db32fb6598d6a93e6e88796a8632 gperf-3.0.4.tar.gz"