aboutsummaryrefslogtreecommitdiffstats
path: root/main/gpsd
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 17:46:23 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-03 15:10:15 +0000
commit6476db411c371241ad7f977abc5246bfb2fa1ee4 (patch)
tree16ca823958e289718a8f36ab2267c1f7687ec804 /main/gpsd
parent4f59f562e235aaf0ec0811ece7ae91d1361c94be (diff)
downloadaports-6476db411c371241ad7f977abc5246bfb2fa1ee4.tar.bz2
aports-6476db411c371241ad7f977abc5246bfb2fa1ee4.tar.xz
main/gpsd: fix build with new scons
Diffstat (limited to 'main/gpsd')
-rw-r--r--main/gpsd/0001-workaround-for-scons-using-python2.patch271
-rw-r--r--main/gpsd/APKBUILD4
2 files changed, 273 insertions, 2 deletions
diff --git a/main/gpsd/0001-workaround-for-scons-using-python2.patch b/main/gpsd/0001-workaround-for-scons-using-python2.patch
index 755f241716..887d10a641 100644
--- a/main/gpsd/0001-workaround-for-scons-using-python2.patch
+++ b/main/gpsd/0001-workaround-for-scons-using-python2.patch
@@ -38,3 +38,274 @@ index 745c765..2e1b73a 100755
# -*- coding: UTF-8
'''
zerk -- GREIS configurator and packet decoder
+ diff --git a/contrib/ntpshmviz b/contrib/ntpshmviz
+index 5aa0016..371fd70 100755
+--- a/contrib/ntpshmviz
++++ b/contrib/ntpshmviz
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ '''
+ ntpshmviz - graph the drift of NTP servers
+ Written by Keane Wolter <daemoneye2@gmail.com>
+diff --git a/contrib/skyview2svg b/contrib/skyview2svg
+index 7fdc327..3ed04c3 100644
+--- a/contrib/skyview2svg
++++ b/contrib/skyview2svg
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ """
+ skyview2svg -- Create an SVG image of GPS satellites sky view.
+diff --git a/contrib/webgps.py b/contrib/webgps.py
+index 99a70c6..a1bcbd2 100755
+--- a/contrib/webgps.py
++++ b/contrib/webgps.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # encoding: utf-8
+
+ """webgps.py
+diff --git a/devtools/ais.py b/devtools/ais.py
+index f269433..531a4c7 100755
+--- a/devtools/ais.py
++++ b/devtools/ais.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # A Python AIVDM/AIVDO decoder
+ #
+diff --git a/devtools/aivdmtable b/devtools/aivdmtable
+index c572070..89f9e0d 100755
+--- a/devtools/aivdmtable
++++ b/devtools/aivdmtable
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Generate an asciidoc table of the six-bit encoding used in AIVDM packets.
+ #
+diff --git a/devtools/cycle_analyzer b/devtools/cycle_analyzer
+index 53ddd51..6992c10 100755
+--- a/devtools/cycle_analyzer
++++ b/devtools/cycle_analyzer
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is Copyright (c) 2010 by the GPSD project
+ # BSD terms apply: see the file COPYING in the distribution root for details.
+diff --git a/devtools/flocktest b/devtools/flocktest
+index d301ee7..8cf2d9e 100755
+--- a/devtools/flocktest
++++ b/devtools/flocktest
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is Copyright (c) 2010 by the GPSD project
+ # BSD terms apply: see the file COPYING in the distribution root for details.
+diff --git a/devtools/identify_failing_build_options.py b/devtools/identify_failing_build_options.py
+index ec10a84..480a3fb 100755
+--- a/devtools/identify_failing_build_options.py
++++ b/devtools/identify_failing_build_options.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # This code runs compatibly under Python 2 and 3.x for x >= 2.
+ # Preserve this property!
+diff --git a/devtools/regress-builder b/devtools/regress-builder
+index 67df358..1ea75fd 100755
+--- a/devtools/regress-builder
++++ b/devtools/regress-builder
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is Copyright (c) 2010 by the GPSD project
+ # BSD terms apply: see the file COPYING in the distribution root for details.
+diff --git a/devtools/regressdiff b/devtools/regressdiff
+index fa658c1..0f85a72 100755
+--- a/devtools/regressdiff
++++ b/devtools/regressdiff
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Walk through a pair of textfiles looking for where they begin to differ.
+ # May be useful for comparing logs when regression tests break.
+diff --git a/devtools/sizes b/devtools/sizes
+index b8afa6e..11e39ab 100755
+--- a/devtools/sizes
++++ b/devtools/sizes
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # sizes -- explore the sizes of static gpsd binaries
+ #
+diff --git a/devtools/striplog b/devtools/striplog
+index 5c63dda..70d41ad 100755
+--- a/devtools/striplog
++++ b/devtools/striplog
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # striplog -- strip leading lines from logs
+ #
+diff --git a/devtools/tablegen.py b/devtools/tablegen.py
+index b8a3ed3..f42a59e 100755
+--- a/devtools/tablegen.py
++++ b/devtools/tablegen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This tool is intended to automate away the drudgery in bring up support
+ # for a new AIS message type. It parses the tabular description of a message
+diff --git a/devtools/test_json_validity.py b/devtools/test_json_validity.py
+index 959bfe8..cac10da 100755
+--- a/devtools/test_json_validity.py
++++ b/devtools/test_json_validity.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Christian Gagneraud - 2012
+ # Simple python script that will parse json dictionaries on its input,
+diff --git a/devtools/uninstall_cleanup.py b/devtools/uninstall_cleanup.py
+index e78d412..916fbab 100755
+--- a/devtools/uninstall_cleanup.py
++++ b/devtools/uninstall_cleanup.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # This code runs compatibly under Python 2 and 3.x for x >= 2.
+ # Preserve this property!
+diff --git a/gegps b/gegps
+index 51af633..945e730 100755
+--- a/gegps
++++ b/gegps
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ '''
+ usage: gegps [-i] [-d kmldir]
+diff --git a/gps/gps.py b/gps/gps.py
+index 7835c5e..f0ed6f4 100644
+--- a/gps/gps.py
++++ b/gps/gps.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ '''gps.py -- Python interface to GPSD.
+
+diff --git a/gpsprof b/gpsprof
+index 2f0c60e..a8715b3 100755
+--- a/gpsprof
++++ b/gpsprof
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ '''
+ Collect and plot latency-profiling data from a running gpsd.
+diff --git a/jsongen.py b/jsongen.py
+index db4b871..ed0fde7 100755
+--- a/jsongen.py
++++ b/jsongen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is Copyright (c) 2010 by the GPSD project
+ # SPDX-License-Identifier: BSD-2-clause
+diff --git a/leapsecond.py b/leapsecond.py
+index aa5a80c..5fc657e 100755
+--- a/leapsecond.py
++++ b/leapsecond.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ """
+
+ Usage: leapsecond.py [-v] { [-h] | [-f filename] | [-g filename]
+diff --git a/maskaudit.py b/maskaudit.py
+index d5cdff9..bcdaeed 100755
+--- a/maskaudit.py
++++ b/maskaudit.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is Copyright (c) 2010 by the GPSD project
+ # SPDX-License-Identifier: BSD-2-clause
+diff --git a/test_maidenhead.py b/test_maidenhead.py
+index 665fd49..54804c0 100755
+--- a/test_maidenhead.py
++++ b/test_maidenhead.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Test grid locator conversion.
+ #
+diff --git a/test_misc.py b/test_misc.py
+index 111d8e0..d630771 100755
+--- a/test_misc.py
++++ b/test_misc.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Test gps/misc.py
+ #
+diff --git a/test_xgps_deps.py b/test_xgps_deps.py
+index cb9448e..e1f5301 100755
+--- a/test_xgps_deps.py
++++ b/test_xgps_deps.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ """Test imports needed by X11-based tools."""
+
+ from __future__ import print_function
+diff --git a/valgrind-audit.py b/valgrind-audit.py
+index 749b2fa..30a1817 100755
+--- a/valgrind-audit.py
++++ b/valgrind-audit.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This is a valgrind torture test for the gpsd daemon.
+ # It's not really expected to spot anything as long as we aren't using
+diff --git a/xgps b/xgps
+index af36225..d231ee5 100755
+--- a/xgps
++++ b/xgps
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: UTF-8
+ '''
+ xgps -- test client for gpsd
+diff --git a/xgpsspeed b/xgpsspeed
+index baada44..a4b0ad4 100755
+--- a/xgpsspeed
++++ b/xgpsspeed
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # by
+ # Robin Wittler <real@the-real.org> (speedometer mode)
+
diff --git a/main/gpsd/APKBUILD b/main/gpsd/APKBUILD
index 5aa3f47bef..7104305f56 100644
--- a/main/gpsd/APKBUILD
+++ b/main/gpsd/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A GPS daemon"
arch=all
url="http://catb.org/gpsd/"
license="BSD"
-makedepends="scons python3-dev libcap-dev ncurses-dev"
+makedepends="scons python3-dev libcap-dev ncurses-dev python"
subpackages="$pkgname-dev $pkgname-doc py3-$pkgname:_py $pkgname-clients:_clients"
source="https://download-mirror.savannah.gnu.org/releases/gpsd/$pkgname-$pkgver.tar.gz
timepps.h
@@ -79,7 +79,7 @@ _clients() {
sha512sums="b381b177fcd29089a61aa11f5df2c67473720a6bbc5590ca1c4fda627331c407de01c62caceeddae780626b9a02392e9a770d52a143357e1babdcc2fbff0ed38 gpsd-3.18.1.tar.gz
eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h
b918e4b32a6e8bcd25d126e4f1a78dfdda30837a64e7d829f04b27e138843a1dbec83e64677edd6f88eca8cead511949ee664066de4429641ba248fe5a7768ef gpsd-use-local-timepps-header.patch
-ab64ec2e28a00d94e71218462b755131f4c5c7ac39db5e914135c9009a3b8d7dca2b5762ea0b9b5859785294ed0db42234ff044ef82185b2c08f96a9ba50f4f0 0001-workaround-for-scons-using-python2.patch
+a0ec09823247def7b7cc5cdcc123d1ee8d5ab923b1cf7e400b6b8c35b8315e82c70f4d197dab0f3d3cba979c71c20a989617b3ca0725d4f8fa7c99c02f36ca0c 0001-workaround-for-scons-using-python2.patch
e2af8f52fc2d7e663882b6d12c5f4d709aa267b16eb9aeca2a70d8ecc681ae72359f3efcd1636cde576bc8579e008f242574bc0adfab7252d3e763f039e86135 ttydefaults.patch
a0e7bf206ad51c31195f86f79ef92adca425d7f988534c0f70a2dd3053613f6fc46820d62d0330aaef7ca100b5f2ab781ce9643f25b4c99c844ae66e7eec5cbc gpsd.initd
55d4a51f82d445d3ac93b2855132ef4380908ed045feba6298ed1d0b607cd9054b5325c024dc52b370983ebd5d9b377537aee7d7128c97aa22e3075f4134d404 gpsd.confd"