aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2/cmake.patch
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2019-05-06 21:58:46 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-24 09:03:54 +0000
commitad6c116184b345846b7bd42746d7b4d47871ab05 (patch)
tree4ef42694bc6c109b39faf2fdfe9748623784cd2d /main/graphite2/cmake.patch
parentb5362e45cc85dc700b3b39d30cbb0f543d100e1d (diff)
downloadaports-ad6c116184b345846b7bd42746d7b4d47871ab05.tar.bz2
aports-ad6c116184b345846b7bd42746d7b4d47871ab05.tar.xz
main/graphite2: upgrade to 1.3.13, update
- Updates package to latest version - Fixes bugs.a.o#10329 - Remakes patch to apply cleanly - Updates license to SPDX - Removes empty variables
Diffstat (limited to 'main/graphite2/cmake.patch')
-rw-r--r--main/graphite2/cmake.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
index 87f4dc9813..2b21d6b09f 100644
--- a/main/graphite2/cmake.patch
+++ b/main/graphite2/cmake.patch
@@ -1,5 +1,5 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 89a59af..b69e244 100644
+index b6ac26b..0371b0c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -120,11 +120,7 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
@@ -12,10 +12,10 @@ index 89a59af..b69e244 100644
- target_link_libraries(graphite2 c gcc)
- endif ()
+ target_link_libraries(graphite2 c gcc_s -lssp_nonshared)
- endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ endif()
include(Graphite)
if (BUILD_SHARED_LIBS)
-@@ -153,4 +149,4 @@ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+@@ -156,4 +152,4 @@ endif()
install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)