aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2019-05-06 21:58:46 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-24 09:03:54 +0000
commitad6c116184b345846b7bd42746d7b4d47871ab05 (patch)
tree4ef42694bc6c109b39faf2fdfe9748623784cd2d /main/graphite2
parentb5362e45cc85dc700b3b39d30cbb0f543d100e1d (diff)
downloadaports-ad6c116184b345846b7bd42746d7b4d47871ab05.tar.bz2
aports-ad6c116184b345846b7bd42746d7b4d47871ab05.tar.xz
main/graphite2: upgrade to 1.3.13, update
- Updates package to latest version - Fixes bugs.a.o#10329 - Remakes patch to apply cleanly - Updates license to SPDX - Removes empty variables
Diffstat (limited to 'main/graphite2')
-rw-r--r--main/graphite2/APKBUILD16
-rw-r--r--main/graphite2/cmake.patch6
2 files changed, 7 insertions, 15 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 031bd9663f..68b4e67069 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -2,17 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=graphite2
_realname=${pkgname/2/}
-pkgver=1.3.12
+pkgver=1.3.13
pkgrel=1
pkgdesc="reimplementation of the SIL Graphite text processing engine"
url="http://graphite.sil.org/"
arch="all"
options="!check" # Test suite requires Graphite 1 and py2-fonttools
-license="LGPL-2.1+ OR MPL-2.0+ OR GPL-2.0+"
-depends=""
+license="LGPL-2.1-or-later OR MPL-2.0 OR GPL-2.0-or-later"
depends_dev="freetype-dev"
makedepends="$depends_dev cmake"
-install=""
subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
cmake.patch
@@ -34,10 +32,7 @@ build() {
-DCMAKE_BUILD_TYPE:STRING=Release \
-DGRAPHITE2_COMPARE_RENDERER=OFF \
-DGRAPHITE2_NFILEFACE=ON \
- -DGRAPHITE2_NSEGCACHE=ON
- # fix unwanted -O3 cflag (taken form Debian)
- find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
make
# static
@@ -49,11 +44,8 @@ build() {
-DCMAKE_BUILD_TYPE:STRING=Release \
-DGRAPHITE2_COMPARE_RENDERER=OFF \
-DGRAPHITE2_NFILEFACE=ON \
- -DGRAPHITE2_NSEGCACHE=ON \
-DBUILD_SHARED_LIBS=OFF
- # fix unwanted -O3 cflag (taken form Debian)
- find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
make
}
@@ -68,5 +60,5 @@ package() {
make DESTDIR="$pkgdir/" install
}
-sha512sums="d0aed05b54445a9664435d5aef9d78fc07a89be23d18b7b1339d37412b09faca6da3dc1e72524e4b114724b76aa6f36934e8ab1a01bd0752e353efa075c9e643 graphite2-1.3.12.tar.gz
-ed1edb48adcaf29fd630d039b9436510cd7116a1a2d976a17912068e5446b17c33c099d0a3ac890f138126d80c2e0f3b56b8a4a28999486705e77f519a16adb3 cmake.patch"
+sha512sums="8e2c6047a66b4d8873842de6b9b1909d326512b47a04f483b3a6113b97fd0d47e0da7cf9ecf96e060ca06e5288b49f1300e2fd7165d2d82d6a8eb8cb7d53d33f graphite2-1.3.13.tar.gz
+729fb5ce0b012dca27cda10ec2b8cdf90029394915072f3a11ee4a3ec1b62aa5d810ca118a428419ac88d0dd316b07de557601d1ce079d3f96bfff4be271addb cmake.patch"
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
index 87f4dc9813..2b21d6b09f 100644
--- a/main/graphite2/cmake.patch
+++ b/main/graphite2/cmake.patch
@@ -1,5 +1,5 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 89a59af..b69e244 100644
+index b6ac26b..0371b0c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -120,11 +120,7 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
@@ -12,10 +12,10 @@ index 89a59af..b69e244 100644
- target_link_libraries(graphite2 c gcc)
- endif ()
+ target_link_libraries(graphite2 c gcc_s -lssp_nonshared)
- endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ endif()
include(Graphite)
if (BUILD_SHARED_LIBS)
-@@ -153,4 +149,4 @@ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+@@ -156,4 +152,4 @@ endif()
install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)