aboutsummaryrefslogtreecommitdiffstats
path: root/main/grub/fix-gcc-no-pie-specs.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-22 14:07:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-22 14:22:00 +0000
commit5b05d9838e2aeb8d29ba22e64fdc205445f9e3a0 (patch)
tree64d54828d7226a17160b7ccf610dcde06221cd8a /main/grub/fix-gcc-no-pie-specs.patch
parent5d1c3fc11703f547a43bc4d7b9f089d75efbec60 (diff)
downloadaports-5b05d9838e2aeb8d29ba22e64fdc205445f9e3a0.tar.bz2
aports-5b05d9838e2aeb8d29ba22e64fdc205445f9e3a0.tar.xz
main/grub: move from testing
neeed for ppc64le image
Diffstat (limited to 'main/grub/fix-gcc-no-pie-specs.patch')
-rw-r--r--main/grub/fix-gcc-no-pie-specs.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/grub/fix-gcc-no-pie-specs.patch b/main/grub/fix-gcc-no-pie-specs.patch
new file mode 100644
index 0000000000..b14c0be3cc
--- /dev/null
+++ b/main/grub/fix-gcc-no-pie-specs.patch
@@ -0,0 +1,20 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -1092,7 +1092,7 @@
+ if test x"$grub_cv_target_cc_efiemu64_link_format" = xunknown; then
+ efiemu_excuse="no suitable link format for efiemu64 found"
+ else
+- EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format"
++ EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format -no-pie"
+ fi
+ fi
+ if test x"$enable_efiemu" = xyes && test x"$efiemu_excuse" != x ; then
+@@ -1188,7 +1188,7 @@
+ [# Need that, because some distributions ship compilers that include
+ # `-fPIE' and '-pie' in the default specs.
+ if [ x"$pie_possible" = xyes ]; then
+- TARGET_CFLAGS="$TARGET_CFLAGS -fno-PIE"
++ TARGET_CFLAGS="$TARGET_CFLAGS -no-pie"
+ fi
+ if [ x"$nopie_possible" = xyes ] && [ x"$pie_possible" = xyes ]; then
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -no-pie"