aboutsummaryrefslogtreecommitdiffstats
path: root/main/gsm/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-02 11:05:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-02 11:05:42 +0000
commit1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968 (patch)
tree56ae386c776d4757d47113e9f9cde211cea99772 /main/gsm/APKBUILD
parentbc5b6eeaa67b6879034c863720e865ff76c2290d (diff)
downloadaports-1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968.tar.bz2
aports-1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968.tar.xz
main/flite,gsm: moved from testing
needed by sems
Diffstat (limited to 'main/gsm/APKBUILD')
-rw-r--r--main/gsm/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/main/gsm/APKBUILD b/main/gsm/APKBUILD
new file mode 100644
index 0000000000..e2548140fd
--- /dev/null
+++ b/main/gsm/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gsm
+pkgver=1.0.13
+pkgrel=0
+_soname=1.0.12
+pkgdesc="Shared libraries for GSM speech compressor"
+url="http://www.quut.com/gsm/"
+arch="all"
+license="MIT"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://www.quut.com/gsm/gsm-$pkgver.tar.gz
+ gsm-64bit.patch
+ gsm-makefile.patch
+ gsm-warnings.patch
+ "
+
+_builddir="$srcdir"/gsm-1.0-pl13
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export RPM_OPT_FLAGS="$CFLAGS -fPIC"
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/include/gsm \
+ "$pkgdir"/usr/lib \
+ "$pkgdir"/usr/share/man/man1 \
+ "$pkgdir"/usr/share/man/man3
+
+ make install \
+ INSTALL_ROOT="$pkgdir"/usr \
+ GSM_INSTALL_INC="$pkgdir"/usr/include/gsm \
+ GSM_INSTALL_LIB="$pkgdir"/usr/lib \
+ || return 1
+ cp -p lib/libgsm.so.$_soname "$pkgdir"/usr/lib/ || return 1
+ ln -s libgsm.so.$_soname "$pkgdir"/usr/lib/libgsm.so.1 || return 1
+ ln -s libgsm.so.$_soname "$pkgdir"/usr/lib/libgsm.so || return 1
+
+ ln -s gsm/gsm.h "$pkgdir"/usr/include/
+ rm -f "$pkgdir"/usr/lib/lib*.a
+}
+
+tools() {
+ pkgdesc="GSM speech compressor tools"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="c1ba392ce61dc4aff1c29ea4e92f6df4 gsm-1.0.13.tar.gz
+1e4f975729e58fe309bda013b26020d9 gsm-64bit.patch
+5d7da37bbc094b392c406df24a15958b gsm-makefile.patch
+a04797e67d809de42c77f9bd0027eb34 gsm-warnings.patch"