aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-bad
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-04-05 12:40:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:28 +0000
commit53a2ede7c4814fc1d6bcf1307cf88dd1a48a016d (patch)
treef3c1084b4b41248d92e9e5c40110e7d799edba8c /main/gst-plugins-bad
parentcd22a966404dbef8aec3d78c838904a11137a7f1 (diff)
downloadaports-53a2ede7c4814fc1d6bcf1307cf88dd1a48a016d.tar.bz2
aports-53a2ede7c4814fc1d6bcf1307cf88dd1a48a016d.tar.xz
main/gstreamer, main/gst-plugins-[base,good,bad,ugly]
main/gstreamer: Clarify license main/gst-plugins-base: Clarify license, update configure options main/gst-plugins-good: Clarify license, update configure options, add Qt and Gtk-3 plugins as separate packages main/gst-plugins-bad: Clarify license, updte configure options, fix compile against libressl main/gst-plugins-ugly: Clarify license, updte configure options
Diffstat (limited to 'main/gst-plugins-bad')
-rw-r--r--main/gst-plugins-bad/APKBUILD23
-rw-r--r--main/gst-plugins-bad/libressl270-dtsl_method.patch18
2 files changed, 29 insertions, 12 deletions
diff --git a/main/gst-plugins-bad/APKBUILD b/main/gst-plugins-bad/APKBUILD
index 2a38ab9ebc..dad3051d84 100644
--- a/main/gst-plugins-bad/APKBUILD
+++ b/main/gst-plugins-bad/APKBUILD
@@ -5,8 +5,7 @@ pkgrel=0
pkgdesc="GStreamer bad plugins"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="LGPL GPL"
-depends=""
+license="GPL-2.0-or-later LGPL-2.0-or-later"
replaces="gst-plugins-bad1"
options="!check" # most fail because: XDG_RUNTIME_DIR not set in the env.
makedepends="
@@ -22,30 +21,30 @@ makedepends="
gsm-dev
gst-plugins-base-dev
gstreamer-dev
- jasper-dev
libdc1394-dev
libexif-dev
libmms-dev
libmodplug-dev
liboil-dev
- libressl-dev
+ libressl-dev>=2.7.0
librsvg-dev
libvdpau-dev
libx11-dev
mesa-dev
neon-dev
orc-dev
- sdl2-dev
+ directfb-dev
spandsp-dev
libwebp-dev
x265-dev
- xvidcore-dev
+ libass-dev
+ libsrtp-dev
+ orc-compiler
"
-checkdepends="orc-compiler"
subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
-ldpath="/usr/lib/gstreamer-.0"
-builddir="$srcdir"/gst-plugins-bad-$pkgver
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz
+ libressl270-dtsl_method.patch"
+ldpath="/usr/lib/gstreamer-1.0"
build() {
cd "$builddir"
@@ -77,5 +76,5 @@ doc() {
default_doc
replaces="${pkgname}1-doc"
}
-
-sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz"
+sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz
+82106a8fa7ac01c63c3298c33a3b6177a4115f380d475634ea8ba4c67654f96275ab4b35eb4ea712a997165fefa7e9b65fd6b14ed3cea478c200d7e8d61423c4 libressl270-dtsl_method.patch"
diff --git a/main/gst-plugins-bad/libressl270-dtsl_method.patch b/main/gst-plugins-bad/libressl270-dtsl_method.patch
new file mode 100644
index 0000000000..6ea6085180
--- /dev/null
+++ b/main/gst-plugins-bad/libressl270-dtsl_method.patch
@@ -0,0 +1,18 @@
+--- a/ext/dtls/gstdtlsagent.c
++++ b/ext/dtls/gstdtlsagent.c
+@@ -176,11 +176,11 @@
+
+ ERR_clear_error ();
+
+-#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
+- priv->ssl_context = SSL_CTX_new (DTLS_method ());
+-#else
++//#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
++ // priv->ssl_context = SSL_CTX_new (DTLS_method ());
++//#else
+ priv->ssl_context = SSL_CTX_new (DTLSv1_method ());
+-#endif
++//#endif
+ if (ERR_peek_error () || !priv->ssl_context) {
+ char buf[512];
+