aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-base
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-29 09:15:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-29 09:28:37 +0000
commit242d999649e2d2b97394b4ee89c8beae99fb2664 (patch)
tree8f8563df5418d5eea6fc9ed6312c3a0129285774 /main/gst-plugins-base
parente93445cd21e0a5c315dea792a63569074981e829 (diff)
downloadaports-242d999649e2d2b97394b4ee89c8beae99fb2664.tar.bz2
aports-242d999649e2d2b97394b4ee89c8beae99fb2664.tar.xz
main/gst*1: rename. remove "1" suffix
Diffstat (limited to 'main/gst-plugins-base')
-rw-r--r--main/gst-plugins-base/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
new file mode 100644
index 0000000000..a11958110e
--- /dev/null
+++ b/main/gst-plugins-base/APKBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-base
+pkgver=1.12.0
+pkgrel=0
+pkgdesc="GStreamer Multimedia Framework Base Plugins"
+url="http://gstreamer.freedesktop.org/"
+arch="all"
+license="GPL LGPL"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=
+depends_dev=""
+makedepends="$depends_dev
+ alsa-lib-dev
+ cdparanoia-dev
+ expat-dev
+ gtk+3.0-dev
+ libice-dev
+ libogg-dev
+ liboil-dev
+ libsm-dev
+ libtheora-dev
+ libvorbis-dev
+ libxv-dev
+ orc-dev
+ perl
+ gobject-introspection-dev
+ gstreamer-dev
+ glib-dev
+ opus-dev
+ "
+source="http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
+ldpath="/usr/lib/gstreamer-.0"
+builddir="$srcdir"/gst-plugins-base-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-experimental \
+ --disable-fatal-warnings \
+ --with-default-audiosink=alsasink \
+ --enable-introspection \
+ --with-package-name="GStreamer Base Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="c7fde1744952ae3b25a2f6fc4f7807ab0137e94a021b8a101dbcd2b612890132b69772b53bf9ae6265d3be14698b3818f2b67cf7e2cc1cc55c33b1891870965a gst-plugins-base-1.12.0.tar.xz"