aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtest
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-28 17:06:18 -0400
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-12 08:13:14 +0000
commit048a120afa315f5e825a9dc74bc3fd2ac93f14ec (patch)
tree9031d94d59feed0a64223d89625b2b8909ff5dc9 /main/gtest
parent3ecc1aceffb955409e0c0c85831d0883422d8c74 (diff)
downloadaports-048a120afa315f5e825a9dc74bc3fd2ac93f14ec.tar.bz2
aports-048a120afa315f5e825a9dc74bc3fd2ac93f14ec.tar.xz
main/gtest: -dev should install libraries too
Using *.pc files is difficult when the libraries are not installed.
Diffstat (limited to 'main/gtest')
-rw-r--r--main/gtest/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/gtest/APKBUILD b/main/gtest/APKBUILD
index 63c701bc0a..6596d39d8d 100644
--- a/main/gtest/APKBUILD
+++ b/main/gtest/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gtest
pkgver=1.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="Google Test - C++ testing utility based on the xUnit framework (like JUnit)"
url="https://github.com/google/googletest"
arch="all"
options="!check" # googletest-death-test-test hangs
license="BSD-3-Clause"
depends=""
-makedepends="python2-dev cmake"
+depends_dev="${pkgname}=${pkgver}-r${pkgrel} gmock=${pkgver}-r${pkgrel} cmake"
+makedepends="$depends_dev python2-dev"
install=""
subpackages="$pkgname-dev gmock"
source="$pkgname-$pkgver.tar.gz::https://github.com/google/googletest/archive/release-$pkgver.tar.gz