aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtkglext
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-05-11 19:34:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:20:14 +0000
commit7151ceb8929179657c74ab10712965d39f417c44 (patch)
treef3e592a746dad3baf22630f087f768d20d62df99 /main/gtkglext
parent270c161fba7add4b908591655a196ccaef5865da (diff)
downloadaports-7151ceb8929179657c74ab10712965d39f417c44.tar.bz2
aports-7151ceb8929179657c74ab10712965d39f417c44.tar.xz
main/gtkglext: fix build break by modifying local variable name conflict
Diffstat (limited to 'main/gtkglext')
-rw-r--r--main/gtkglext/APKBUILD4
-rw-r--r--main/gtkglext/gtkglext-local-parm.patch20
2 files changed, 23 insertions, 1 deletions
diff --git a/main/gtkglext/APKBUILD b/main/gtkglext/APKBUILD
index f54e73f3a6..71ada076e5 100644
--- a/main/gtkglext/APKBUILD
+++ b/main/gtkglext/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gtkglext
pkgver=1.2.0
-pkgrel=11
+pkgrel=12
pkgdesc="GTK+ OpenGL Extension"
url="https://projects.gnome.org/gtkglext/"
arch="all"
@@ -14,6 +14,7 @@ makedepends="$depends_dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ gtkglext-local-parm.patch
gtkglext-deprecated.patch"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -44,4 +45,5 @@ package() {
}
sha512sums="464203531698703d47dfb0746663f10c889f48542dd5d7a6e3dd6c6a197de4089628e2d39601d3ccbe3436ee396260eaa1f09220ecf04ba12891939209a7dc50 gtkglext-1.2.0.tar.gz
+da398ad6782c540f3494f5bebb566e338a0a7ccb171453b1b9f9dc2e387d965f73cfd4ead8b63ab6a009e150e20f76f0b2ddc3636a8af241fa1a0aadeb650d67 gtkglext-local-parm.patch
bca7526f014a1ebd1453fd295a02f43e29729232e732ade8e361d718e3005433a112ca5367a366ebd31c4d52cf8aa6c360fe3e315b85182e7fe5185dd163618f gtkglext-deprecated.patch"
diff --git a/main/gtkglext/gtkglext-local-parm.patch b/main/gtkglext/gtkglext-local-parm.patch
new file mode 100644
index 0000000000..5320394e0a
--- /dev/null
+++ b/main/gtkglext/gtkglext-local-parm.patch
@@ -0,0 +1,20 @@
+--- a/gdk/gdkglshapes.c
++++ b/gdk/gdkglshapes.c
+@@ -544,7 +544,7 @@
+ {-Z, -X, 0}
+ };
+
+-static int index[20][3] =
++static int loc_index[20][3] =
+ {
+ {0, 4, 1},
+ {0, 9, 4},
+@@ -574,7 +574,7 @@
+ int i;
+
+ for (i = 19; i >= 0; i--) {
+- drawtriangle(i, idata, index, shadeType);
++ drawtriangle(i, idata, loc_index, shadeType);
+ }
+ }
+