aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtkmm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-11 08:44:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-11 08:51:55 +0000
commitc0736f4e83881763cee2a5b0a83f81dae80fece6 (patch)
treec762b169da22f53b6e5a6c1796ede12a358a3ab1 /main/gtkmm
parent7148688001f55ce0fae5a4549d0b6d77a4c6abc8 (diff)
downloadaports-c0736f4e83881763cee2a5b0a83f81dae80fece6.tar.bz2
aports-c0736f4e83881763cee2a5b0a83f81dae80fece6.tar.xz
main/gtkmm: fix build with new sigc++
sigc++ now uses c++11 features so we need build in C++11 mode.
Diffstat (limited to 'main/gtkmm')
-rw-r--r--main/gtkmm/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/gtkmm/APKBUILD b/main/gtkmm/APKBUILD
index 0e895ad57f..018c9b2d17 100644
--- a/main/gtkmm/APKBUILD
+++ b/main/gtkmm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtkmm
pkgver=2.24.4
-pkgrel=2
+pkgrel=3
pkgdesc="C++ wrappers for GTK+"
url="http://gtkmm.sourceforge.net/"
arch="all"
@@ -20,6 +20,7 @@ prepare() {
build() {
cd "$_builddir"
+ CXXFLAGS="$CXXFLAGS -std=c++11" \
./configure \
--build=$CBUILD \
--host=$CHOST \